Team Chevelle banner
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
i have a chevelle, 1972 350v8 and after i drive it about 5 mins, i lose power, not like all power but my chevelle when i push in the gas petal, to the floor it dont have as much power as when i first drive it, but its never stalled on me? its almost like it wouldn't get enough fuel? idk
 

·
Premium Member
Joined
·
4,136 Posts
Disconnect your exhaust system at the exhaust manifolds and see if that makes a difference. GM back in the day had an issue with double wall exhaust pipes having condensation between the walls turn to steam and collapse the pipes. They sorta uncollapse when they cool and recollapse when they get hot. It's a noisy test but it proves the exhaust is either good or bad.

If your car has been converted from stock, cancel my comment.
 

·
Banned
Joined
·
831 Posts
Check :
fuel filter
Plugs
carb

-Spray some B12, Gumbout, etc..... Carb cleaner spray
*make be some dirt or some type of carbon build up in the carb...
-Fuel filter:
*filter maybe restricted, partially plugged, not enough microns...Paper elements can become restricted by debris from the tank and they can collapse worse case.....
-plugs:
*plugs maybe too cold, fouled, loose wire to plug connection and not providing enough power.... Gap can also be off on the plug.....If HEI and performance wire gap to .045

These are cheap easy checks and balances......
Problems with lack of power during acceleration is usually due to a fuel delievery problem......

If none of these help, then check timing, carb mixture screws, etc.....
 
1 - 4 of 4 Posts
Top