Team Chevelle banner
  • Hey everyone! Enter your ride HERE to be a part JULY's Ride of the Month Challenge!
1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
newbie here...just getting started learning with my son. I have a 1969 with 396. the tach isn't working. anyone have idea for troubleshooting?
 

·
Premium Member
Joined
·
1,021 Posts
Welcome to the site.
Was it working and stopped working or have you seen it work in the past?
Post some pics of the car too.
 

·
Premium Member
Joined
·
231 Posts
Welcome to the site. When I first got my '69 the tach didn't work either. After I got the dash area removed I found that it was wired backwards. Fixing that took care of it. I hope yours is that simple.
 

·
Registered
1969 Chevelle 2 Door Sport Coupe Malibu COPO clone
Joined
·
5,668 Posts
newbie here...just getting started learning with my son. I have a 1969 with 396. the tach isn't working. anyone have idea for troubleshooting?
:cool: Welcome to the best forum on the web. If you decide to remove the dash do a search of this site PRIOR to starting. It's an involved process, and will take a new guy 20 hours of frustration (after you do it a couple of times there's less of both). There is a bunch of good info on how to best tackle a dash removal and re-install.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #7 ·
i bought it without the temperature gage and tach not working. battery, fuel level, oil pressure are all good. i was hoping i didn't have to remove anything (including dash) to get this done

i'll try to add pictures she's a beauty. 396 SS 375HP, pearl white interior, white convertible top, red exterior. factory air, front disc brake, pwr top, pwr steering, power brakes
 
1 - 7 of 7 Posts
Top