Team Chevelle banner
  • Hey everyone! Enter your ride HERE to be a part JULY's Ride of the Month Challenge!
1 - 8 of 8 Posts

·
Premium Member
Joined
·
629 Posts
Discussion Starter · #1 ·
My fuse box was damaged during storage when something fell on it. I had a trashed harness with a good box in one of my parts cars. I made several pictures of where the wires plug in to the terminals, but my phone updated and I lost the pics. Does anyone have a picture of the wiring to the the terminals they could post? A google search came up empty... Thanks in advance.
 

·
Premium Member
Joined
·
4,507 Posts
My fuse box was damaged during storage when something fell on it. I had a trashed harness with a good box in one of my parts cars. I made several pictures of where the wires plug in to the terminals, but my phone updated and I lost the pics. Does anyone have a picture of the wiring to the the terminals they could post? A google search came up empty... Thanks in advance.
Terry, PM me. I have a 67 fuse block & harness, but it'll be Saturday before I can take a photo for you.
 

·
Premium Member
Joined
·
4,507 Posts
Thanks. I need a pic of the backside to see where the wires plug up on the spade terminals so I can plug them up to the correct fuses...
Terry, I mis-understood what you needed to see. I took a picture of the front of the fuse block. I now see you wanted the backside where the spade connectors attach. Sorry about that. All these years I thought the load connections were hard-wired to the fuse block, you learn something new every day.
 

·
Premium Member
Joined
·
629 Posts
Discussion Starter · #8 ·
No problem. I believe 6 are spade type ends and 6 are the ones with the fuse holder terminal on them. They are all removable with the correct tools though...
 
1 - 8 of 8 Posts
Top