Chevelle Tech - View Profile: 450HPChevelle
450HPChevelle's Profile Picture

450HPChevelle 450HPChevelle is offline

Lifetime Premium Member

  Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. Jason 70 SS
    Mar 18th, 11 9:26 PM - permalink
    Jason 70 SS
    Hi, I was reading older posts and noticed you had the same problem I do now with your oil pump. I have been restoring a 70 454 for a while now. Finally got her running, drove around the yard for a few minutes, parked it. I noticed the oil smelled like fuel, so I changed it, along with the filter. When I started it back up, oil came gushing from the filter area. After cleaning it up and looking for any issues, replaced with an AC Delco filter and same thing. What was the outcome of your issue? Did you have to change out the oil pump? I am guessing you had to pull the engine to do it, right? Thank you, Jason

  About Me

  • About 450HPChevelle
    Location
    Zeeland, Mi.
    Interests
    Spending time w/my family, and going to carshows.Especially ones with Chevelles!
    Occupation
    Process Tech.
    Piston Factor
    34
    Currently own:
    2013 Nickey Camaro convt.

    2000 Silverado 1500LT Ext. cab
    2006 Chrysler 300C (HD)(Wife's)
    John Deere 345 garden tractor 54in. deck
    Photo Link
    http://
    First Name
    Brian
  • Signature
    1970 Chevelle SS 396: (SOLD) but not forgotten!
    New Ride 2013 Nickey Camaro Convt.800HP @ Crank Yeah baby!
    https://www.chevelles.com/forums/members/10451-450hpchevelle-albums-bowtie-bri-s-ride-k-450hpchevelle.html
    Brian Henderson
    A.C.E.S. #5637 T.C.#1932

  Statistics

Total Posts
Albums
Visitor Messages
General Information
  • Last Activity: Oct 27th, 18 1:03 AM
  • Join Date: Mar 11th, 02
  • Referrals: 0

  Friends

Showing Friends 1 to 3 of 3

  Mentions

No results to display...

  Quotes

No results to display...
For the best viewing experience please update your browser to Google Chrome