Sniper surging all of a sudden - Chevelle Tech
EFI Caution: Beyond here be monsters...

 1Likes
Reply
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 30 (permalink) Old Jun 17th, 19, 8:19 PM Thread Starter
Lifetime Premium Member
sam
 
Join Date: Dec 2008
Location: utica, ny
Posts: 429
Garage
Sniper surging all of a sudden

I just installed a new sniper system, have put about 150 miles on it. It just started surging both in gear and in park. It revs and idles up and down. Map and IAC #s are all over. Map up and down into the 50ís, IAC goes from zero and blips in the 40ís and back. What could have happened? Any ideas?

1967 Royal Plum, 434BB, AFR Heads, 3.90 gears, New Chris Straub Hyd Roller!, 200r4
scalise71 is offline  
Sponsored Links
Advertisement
 
post #2 of 30 (permalink) Old Jun 17th, 19, 9:01 PM
Tech Team
 
Join Date: Oct 2017
Posts: 83
Re: Sniper surging all of a sudden

Quote:
Originally Posted by scalise71 View Post
I just installed a new sniper system, have put about 150 miles on it. It just started surging both in gear and in park. It revs and idles up and down. Map and IAC #s are all over. Map up and down into the 50ís, IAC goes from zero and blips in the 40ís and back. What could have happened? Any ideas?
Vacuum leak?

Sent from my SM-G965U using Tapatalk
Peewee0413 is offline  
post #3 of 30 (permalink) Old Jun 17th, 19, 9:02 PM
Tech Team
 
Join Date: Oct 2017
Posts: 83
Re: Sniper surging all of a sudden

AFR all over the place?

Sent from my SM-G965U using Tapatalk
Peewee0413 is offline  
 
post #4 of 30 (permalink) Old Jun 17th, 19, 9:03 PM Thread Starter
Lifetime Premium Member
sam
 
Join Date: Dec 2008
Location: utica, ny
Posts: 429
Garage
Re: Sniper surging all of a sudden

No AFR is adjusting as it has been

1967 Royal Plum, 434BB, AFR Heads, 3.90 gears, New Chris Straub Hyd Roller!, 200r4
scalise71 is offline  
post #5 of 30 (permalink) Old Jun 17th, 19, 9:07 PM
Tech Team
 
Join Date: Oct 2017
Posts: 83
Re: Sniper surging all of a sudden

I'd check for disconnected hoses. Usually the most likey cause for surges. If it's missing I'd check timing then plugs/wires if no hose is off.

Sent from my SM-G965U using Tapatalk
Peewee0413 is offline  
post #6 of 30 (permalink) Old Jun 17th, 19, 9:26 PM Thread Starter
Lifetime Premium Member
sam
 
Join Date: Dec 2008
Location: utica, ny
Posts: 429
Garage
Re: Sniper surging all of a sudden

PCV is only hose I have and itís intact

1967 Royal Plum, 434BB, AFR Heads, 3.90 gears, New Chris Straub Hyd Roller!, 200r4
scalise71 is offline  
post #7 of 30 (permalink) Old Jun 17th, 19, 9:55 PM
Bernard
 
Join Date: Sep 2014
Location: New York
Posts: 12
Re: Sniper surging all of a sudden

Check the EFI studs. Are they down tight?
burn6si is offline  
post #8 of 30 (permalink) Old Jun 17th, 19, 9:58 PM Thread Starter
Lifetime Premium Member
sam
 
Join Date: Dec 2008
Location: utica, ny
Posts: 429
Garage
Re: Sniper surging all of a sudden

Quote:
Originally Posted by burn6si View Post
Check the EFI studs. Are they down tight?
I checked them and they were pretty tight, snugged them more, and still did it. This was one of the first things I tried. I appreciate the ideas so far.

1967 Royal Plum, 434BB, AFR Heads, 3.90 gears, New Chris Straub Hyd Roller!, 200r4
scalise71 is offline  
post #9 of 30 (permalink) Old Jun 17th, 19, 10:36 PM
Tech Team
 
Join Date: Oct 2017
Posts: 83
Re: Sniper surging all of a sudden

Well reset it and see if it runs better. Have you messed with settings recently? If it still surges after resetting then its mechanical.

Sent from my SM-G965U using Tapatalk
Peewee0413 is offline  
post #10 of 30 (permalink) Old Jun 18th, 19, 6:33 AM Thread Starter
Lifetime Premium Member
sam
 
Join Date: Dec 2008
Location: utica, ny
Posts: 429
Garage
Re: Sniper surging all of a sudden

I havenít messed with any settings, because it was running great. I just had it idling after taking a ride, and I was reading up on the IAC because I have had a whistling under acceleration that I was going to try to work on. How do I reset the system?

1967 Royal Plum, 434BB, AFR Heads, 3.90 gears, New Chris Straub Hyd Roller!, 200r4
scalise71 is offline  
post #11 of 30 (permalink) Old Jun 18th, 19, 7:43 AM
Tech Team
 
Join Date: Oct 2017
Posts: 83
Re: Sniper surging all of a sudden

Quote:
Originally Posted by scalise71 View Post
I havenít messed with any settings, because it was running great. I just had it idling after taking a ride, and I was reading up on the IAC because I have had a whistling under acceleration that I was going to try to work on. How do I reset the system?
Whistle under acceleration???? Probably a vacuum leak since there an idle problem with the sound. Dont reset it. Find the vacuum leak. Lol

Sent from my SM-G965U using Tapatalk
Peewee0413 is offline  
post #12 of 30 (permalink) Old Jun 18th, 19, 8:12 AM Thread Starter
Lifetime Premium Member
sam
 
Join Date: Dec 2008
Location: utica, ny
Posts: 429
Garage
Re: Sniper surging all of a sudden

I will look for a leak but info on the sniper I have seen, suggests that the whistle will sometimes self tune out, and or is an IAC adjustment as the IAC acts at kind of a (controlled vacuum leak) I just checked all ports on the TBI and the two small ones are capped. The PCV line is tight. when I turn on the key, IAC reads 72 with car off.

1967 Royal Plum, 434BB, AFR Heads, 3.90 gears, New Chris Straub Hyd Roller!, 200r4

Last edited by scalise71; Jun 18th, 19 at 8:29 AM.
scalise71 is offline  
post #13 of 30 (permalink) Old Jun 18th, 19, 8:44 AM
Senior Tech Team
Ed
 
Join Date: Aug 2013
Location: Pittsburgh, PA
Posts: 3,839
Garage
Re: Sniper surging all of a sudden

Check fuel pressure while it is happening. Also check voltage at fuel pump while it is happening.

1967 El Camino Malibu - Deepwater Blue
ZZ4 350, FiTech 600 complete!,Roadmaster tank, 700R4, Underdash A/C in progress, JGC Steering, 1990s truck serpentine.
Pioneer4x4 is offline  
post #14 of 30 (permalink) Old Jun 18th, 19, 8:57 AM
Tech Team
 
Join Date: Oct 2017
Posts: 83
Re: Sniper surging all of a sudden

I agree. Poor idle can sometimes cause IAC to open and could whistle. Sure IAC isn't closed during acceleration.

Sent from my SM-G965U using Tapatalk
Peewee0413 is offline  
post #15 of 30 (permalink) Old Jun 18th, 19, 10:44 AM Thread Starter
Lifetime Premium Member
sam
 
Join Date: Dec 2008
Location: utica, ny
Posts: 429
Garage
Re: Sniper surging all of a sudden

I adjusted the IAC just now with the car warmed up, the map is still in the 50ís. Car was in the high 180s for temps when I had the issues. I didnít notice any surges at idle on cold start or when warmed up in the 160s today.

1967 Royal Plum, 434BB, AFR Heads, 3.90 gears, New Chris Straub Hyd Roller!, 200r4
scalise71 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevelle Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address. Note, you will be sent a confirmation request to this address.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome