66 - Shakie - Page 9 - Chevelle Tech
Pro Touring Todays performance with classic style

 1Likes
Reply
 
LinkBack Thread Tools Search this Thread Display Modes
post #121 of 129 (permalink) Old Dec 9th, 16, 8:26 PM
Tech Team
Rod
 
Join Date: Sep 2015
Location: California, MO
Posts: 625
Garage
Re: 66 - Shakie

looking good, Jim. It won't be too much longer and you'll have her in primer and ready to block and shoot!

1966 Malibu, 540 BBC FAST XFI EFI, 4L80E Trans, 2800 Stall, Quick Performance 59" 9" Ford Rear End w/3.50 gear
66 Bu is offline  
Sponsored Links
Advertisement
 
post #122 of 129 (permalink) Old Dec 9th, 16, 10:30 PM Thread Starter
Tech Team
Jim
 
Join Date: Jul 2015
Location: Austin, TX
Posts: 104
Re: 66 - Shakie

Thanks. I sure hope so. I am hoping to have her up and running by late spring.

Quote:
Originally Posted by 66 Bu View Post
looking good, Jim. It won't be too much longer and you'll have her in primer and ready to block and shoot!
Austin_Jim is offline  
post #123 of 129 (permalink) Old Dec 10th, 16, 8:13 PM
Lifetime Premium Member
Mike
 
Join Date: Dec 2003
Location: Rochester, IL
Posts: 1,083
Re: 66 - Shakie

Wow, they are moving right along. Congrats!

Mike
66 Chevelle Pro Touring build in progress


My 66 Chevelle build thread-
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Mike McMasters is offline  
 
post #124 of 129 (permalink) Old Dec 11th, 16, 5:03 PM Thread Starter
Tech Team
Jim
 
Join Date: Jul 2015
Location: Austin, TX
Posts: 104
Re: 66 - Shakie

To me, it seems like forever, but definitely making progress.

Quote:
Originally Posted by Mike McMasters View Post
Wow, they are moving right along. Congrats!
Austin_Jim is offline  
post #125 of 129 (permalink) Old Jan 4th, 17, 11:52 AM Thread Starter
Tech Team
Jim
 
Join Date: Jul 2015
Location: Austin, TX
Posts: 104
Re: 66 - Shakie

Looks like we might be finally finished cutting out the rusty parts, patching and replacing pieces. The final pieces were the back of the rear wheel-housings where they meet the trunk floor and the rear braces where the body mounts to the trunk. They were almost completely gone. Someone totally botched that area to the point I had no idea what to look for for the replacement pieces. At any rate, I found them and they are now back in.

Cut out and ready for new pieces:


You can see some of the repair to the rear wheel-house. Still needs to be cleaned up:


Passenger side:


New brace:


Drivers inside frame rail:
Austin_Jim is offline  
post #126 of 129 (permalink) Old Jan 4th, 17, 4:03 PM
Lifetime Premium Member
Mike
 
Join Date: Dec 2003
Location: Rochester, IL
Posts: 1,083
Re: 66 - Shakie

great work!

Mike
66 Chevelle Pro Touring build in progress


My 66 Chevelle build thread-
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Mike McMasters is offline  
post #127 of 129 (permalink) Old Jan 4th, 17, 7:59 PM
Lifetime Premium Member
Dan
 
Join Date: Jan 2003
Location: Grafton, MA
Posts: 753
Re: 66 - Shakie

Keep it moving Jim. Burnouts in no time!

Build thread-
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Album -
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Dan65ss is offline  
post #128 of 129 (permalink) Old Jan 4th, 17, 8:02 PM Thread Starter
Tech Team
Jim
 
Join Date: Jul 2015
Location: Austin, TX
Posts: 104
Re: 66 - Shakie

Thanks guys. Getting there...
Austin_Jim is offline  
post #129 of 129 (permalink) Old Mar 30th, 17, 3:05 PM Thread Starter
Tech Team
Jim
 
Join Date: Jul 2015
Location: Austin, TX
Posts: 104
Re: 66 - Shakie

Been WAY too long. The body shop has had a couple other projects that they need to get out. Not a big deal. I'm excited to get the car back, but not in a rush. I pay for time and materials as work gets done weekly, so it's not like they have a big pile of my cash. They finished off removing the drip rails and installing the Kindigit door handles. Pics:







Austin_Jim is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevelle Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address. Note, you will be sent a confirmation request to this address.

Email Address:
OR

Log-in









Old Thread Warning
This Thread is more than 984 days old. It is very likely that it does not need any further discussion and thus bumping it serves no purpose.
If you still feel it is necessary to make a new reply, you can still do so though.

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome