Correct water pump for 1970 396 w/ a/c? - Chevelle Tech
Restoration Corner Where originality comes first.

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 3 (permalink) Old Nov 12th, 12, 10:02 PM Thread Starter
Lifetime Premium Member
Mark
 
Join Date: Feb 2006
Location: Virginia
Posts: 228
Correct water pump for 1970 396 w/ a/c?

I apologize for the dumb question, but I just want to confirm the correct water pump for a 1970 SS-396/350 hp with air conditioning. I searched the Forum archives and #3969811 is cited several times as the correct part number for the engine and there are multiple references to getting a rebuilt one from NAPA or having your original one rebuilt by Jeff at DC Parts, Jerry Rey in Tulsa, or Arthur Gould Rebuilding. My confusion comes from the NAPA website listing the 3969811 for non-a/c cars and a different water pump for cars with a/c (but it doesn't give the GM part number and it doesn't look like the pump on my engine). Does it matter if the car has a/c or is #3969811 correct for all L-34 396 (402) engines? Thanks for your assistance and patience!
Mark2Mac is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Nov 12th, 12, 10:24 PM
Lifetime Premium Member
Tom
 
Join Date: Nov 2000
Location: Franklinville, NJ
Posts: 16,217
Garage
Send a message via AIM to BlueSS454
Re: Correct water pump for 1970 396 w/ a/c?

The 811 pump is correct for 69-72 big block cars. NAPA can send them out for a rebuild if you drop your core off. I get my water pumps rebuilt locally. It's much cheaper. IIRC, it cost me $45 to have one rebuilt.

Tom Rightler, MCC VP & Newsletter Editor

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Best ET: [email protected] MPH

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
BlueSS454 is offline  
post #3 of 3 (permalink) Old Nov 13th, 12, 12:02 AM Thread Starter
Lifetime Premium Member
Mark
 
Join Date: Feb 2006
Location: Virginia
Posts: 228
Re: Correct water pump for 1970 396 w/ a/c?

Thanks, Tom--I appreciate the info.
Mark2Mac is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevelle Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address. Note, you will be sent a confirmation request to this address.

Email Address:
OR

Log-in









Old Thread Warning
This Thread is more than 2506 days old. It is very likely that it does not need any further discussion and thus bumping it serves no purpose.
If you still feel it is necessary to make a new reply, you can still do so though.

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome