4L60E or 80E problem - Chevelle Tech
Transmission & Driveline Transmissions and Differentials

 1Likes
  • 1 Post By paul bell
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 7 (permalink) Old May 26th, 19, 10:14 AM Thread Starter
Lifetime Premium Member
rick
 
Join Date: Jul 2012
Location: st. pete. , fla
Posts: 5,712
Garage
4L60E or 80E problem

I have a 2005 chevy express 2500 4.8 litre with 1 of these trans but not sure which, it's got 150K mi. and acting odd leaving red lights & stop signs some times the van will act like it's not in gear when I give it gas then it feels like I had it in neutral revved it a little and dropped it in gear, fluid is full but does have a burnt smell and getting dark in color, will this need a total rebuild ? it's also my DD work van, tia, rick.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
shovelrick is online now  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old May 26th, 19, 2:24 PM
Tech Team
Rick
 
Join Date: May 2017
Location: Bossier City, Louisiana
Posts: 764
Re: 4L60E or 80E problem

I'd drop the pan and see what's in there as far as shedding clutch material off the disks.

The web has pictures of the shapes of various trans pans to indicate whether it's a 4L60E or a 4L80E.

Does it throw any OBD II codes? I'd have to think with that much slippage, it would throw a code or two for slippage.

Could be a pump problem that takes some revved up rpm to get the torque converter to engage. A pressure gauge would be good here.

Rick

Sent from my SM-G965U using Tapatalk

1970 El Camino under Reconstruction - 5.3L LS VORTEC Engine and 4L60E Transmission
B52bombardier1 is offline  
post #3 of 7 (permalink) Old May 26th, 19, 2:37 PM
Lifetime Premium Member
Brian
 
Join Date: Jun 2003
Location: Mesa, AZ
Posts: 3,121
Garage
Re: 4L60E or 80E problem

Being a 2500, it should be a 4L80E (that is what Rockauto shows). If it needs to be rebuilt, I would just purchase one from an Autonation dealer. They come with a 3 year, 100,000 mile warranty. If anything goes wrong, the dealer fixes it.

If you know someone with an account at one of those dealerships, you can get it a little cheaper. The prices I am seeing are around $2,600, with a $700 core charge. Buying it local would save you the core charge (you would just take yours out and have it with you when you purchase the new one). You will need your transmission code - apparently there are two different ones.

https://www.chevroletpartsdirect.com...QtOGwtdjgtZ2Fz

https://www.gmpartsonline.net/auto-p...nsmission-scat

1971 Malibu, factory buckets/full gauges/console, 377 roller cammed small block, Turbo 400, 3.42 10 bolt posi (Buick), - All your base are belong to us.
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


My Chevelle w/ open headers:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


My Chevelle w/ 2.5 pipes + X crossover/18 inch glass packs:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
WakkoWarner is online now  
 
post #4 of 7 (permalink) Old May 26th, 19, 2:48 PM
Lifetime Premium Member
Terry
 
Join Date: Dec 2014
Location: Sacramento, Ca.
Posts: 903
Re: 4L60E or 80E problem

It sounds similar to a problem i had, ended up being the 1-2 shift solenoid. Terry
68-13427 is offline  
post #5 of 7 (permalink) Old May 26th, 19, 5:18 PM Thread Starter
Lifetime Premium Member
rick
 
Join Date: Jul 2012
Location: st. pete. , fla
Posts: 5,712
Garage
Re: 4L60E or 80E problem

I guess I'm taking it to a local trans shop that has a good rep, I bought a trans jack last year (or year before?) but now with a bad neck I can't work on pulling/installing just didn't want to hear $3,000+ if it's a simple repair & fluid/filter


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
shovelrick is online now  
post #6 of 7 (permalink) Old May 30th, 19, 7:31 PM
Tech Team
 
Join Date: Aug 2018
Posts: 380
Re: 4L60E or 80E problem

I fixed a chevy 1500 recently that did the rev/jerk thing. It was low on fluid. Your burned fluid is a pretty bad sign even if it is low.

'71 chevelle, 468, TH400, 12 bolt posi w/3.08's, drinks a lot of 87 octane.
v8440 is offline  
post #7 of 7 (permalink) Old May 30th, 19, 8:13 PM
Senior Tech Team
 
Join Date: Sep 2012
Location: New York City
Posts: 2,111
Re: 4L60E or 80E problem

ACDelco and Rock Auto show as either 4L60e OR the 4L80E being used.

As you're having problems with it, I'd say you have the 4L60E because the 4L80E should NEVER have issues behind a 4.8-unless you've been doing neutral drops.

I'd suggest you do a filter change and replace whatever fluid comes out with fresh. Make sure you clean the pan and magnets real good, at 150K miles, they'll be covered.

Any foaming of the coolant in the radiator? The transmission cooler inside the radiator is prone to leaking and coolant in the transmission fluid is fatal to any automatic transmission. I always suggest eliminating the stock cooler and go external. If you overheat the engine it then heats the transmission-which is also fatal for it.

I had a 1999 GMC Savana 1500 with the 305 engine and the 4L60E transmission. It was rebuilt FIVE TIMES in 100,000 miles. This transmission should never be used in any truck application, regardless of engine.
Kirk's67SS likes this.

LS1tech.com supermoderator.
How may I help you?
1971 Monte Carlo SS454-496ci 600hp
1999 Trans Am-500hp
2003 Iszu Ascender XL Limited V8
paul bell is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevelle Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address. Note, you will be sent a confirmation request to this address.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Battery drain problem Dcairns560 Troubleshooting 23 Dec 13th, 18 1:38 AM
HELP!!!1972 chevelle a/c- heater control problem berneemc Electrical & Wiring 14 Jun 2nd, 15 10:22 AM
Crossmember bolt in not straight across...a problem? Gossamer454 Transmission & Driveline 4 Apr 4th, 15 5:01 AM
frustrating 68 starting problem 68454SS Electrical & Wiring 9 Oct 25th, 14 11:20 PM
temp gauge problem farmboy66 Electrical & Wiring 1 Apr 7th, 13 10:01 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome