'70 base Chevelle dash to Monte SS dash? - Chevelle Tech
Electrical & Wiring Troubleshooting electrical problems.

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 9 (permalink) Old Apr 11th, 16, 8:34 AM Thread Starter
 
Join Date: Apr 2016
Posts: 5
'70 base Chevelle dash to Monte SS dash?

Can I please get pics\advise on wiring a Monte Carlo SS dash in my standard '70 Chevelle non SS gauge dash? The SS dash is bolted in and I only have a horn after hooking up the fuse block plugs?! I now see the ele. prong configuration is all wrong!( I need image on my '70 Chevelle Malibu non a\c SB ,ATrans w\console fuse block plugs and image on a '70 Monte Carlo SS LS5 ATrans fuse bock plugs so I can figure out where the wires need to go to get more then just a horn! I'm sjure this has been done hundreds of times. Thank you in advance.
Glenns70 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old Apr 11th, 16, 9:42 AM
Lifetime Premium Member
Dan
 
Join Date: Dec 2009
Location: Wisconsin
Posts: 6,756
Re: '70 base Chevelle dash to Monte SS dash?

Does the Monte dash have a factory tach in it? Are you still trying to use the sweep dash wire harness for the Monte dash? If so, it will not work. You will need the correct style harness for the Monte dash. You need a gauge dash harness if the gauge cluster has the tach. If it does not have a tach you will need a non gauge/ idiot light harness from a Monte or an SS car. We will need more information to help you through this.
RealRed70 is offline  
post #3 of 9 (permalink) Old Apr 11th, 16, 10:36 AM Thread Starter
 
Join Date: Apr 2016
Posts: 5
Re: '70 base Chevelle dash to Monte SS dash?

Yes the Monte dash does have the tach, it was out of a LS5 SS . I got the dash with the dash harness and the engine harness matching the dash that it came off of. I did not get the fwd lamp harness though(. This sucks.
Glenns70 is offline  
 
post #4 of 9 (permalink) Old Apr 11th, 16, 11:03 AM
Lifetime Premium Member
Dan
 
Join Date: Dec 2009
Location: Wisconsin
Posts: 6,756
Re: '70 base Chevelle dash to Monte SS dash?

It is not that bad at all. You just need to add two wires to the forward lamp harness for the amp gauge. You need to add a black wire with a white stripe to position D-T on the forward lamp harness connector. Attach the other end to one of the positive screws on your horn relay. You will also need to add a black wire to position D-S of the forward lamp harness connector. Attach the other end of it to the junction block on the radiator core support behind the battery. Both of these wires should have fusible links on the ends them where they will be attached. That is the ends to the horn relay and the junction block. You will need a different temperature sending unit in your cylinder head for guages. A non gauge car used a different style that is not correct.
RealRed70 is offline  
post #5 of 9 (permalink) Old Apr 11th, 16, 8:44 PM Thread Starter
 
Join Date: Apr 2016
Posts: 5
Re: '70 base Chevelle dash to Monte SS dash?

Ok, now what about the alternator \ regulator wiring? My original '70 Chevelle is on the fwd lamp harness, and on the Monte, I see the alternator wire plug and heavy red wire are on the engine harness...? I hooked up\plugged in tonight for kicks the original Chevelle fwd lamp harness and the original Monte engine harness that I got with the dash and just placed some wires from the engine harness on some poles of the starter and alternator and plugged in the oil psi switch, tach ect,, and it started?! I have the og harness going to the alternator still and just piggy backed the heavy red wire on the post. I have the horn,dash lamps,tach,gas gauge, oil psi lamp,rear marker lamps ,brake lamps,reverse lamps,ft. high and low beams, marker lamps,amp meter, heater blower. What I do not have is ..No water temp as I do not have the sender or know what wire color to hook up,no wipers\washers as again I do not know what color wires to hook up,and no turn signals, but when I do right..the ft. and rear lamps go on bright, but do not blink, dash indicator as well comes on, but no blink. Left side, no blink or no dash indicator but lamps ft. and rear come on bright when you do the signal lever up and down manually.I did try new flasher relay, but still nothing So I do have something to work with I feel, just must have some wires off or not plugged in.?! Help please?
Glenns70 is offline  
post #6 of 9 (permalink) Old Apr 11th, 16, 9:05 PM Thread Starter
 
Join Date: Apr 2016
Posts: 5
Re: '70 base Chevelle dash to Monte SS dash?

I'm afraid to buy the OG Chevelle SS engine harness and fwd. lamp harness and still have things not work correctly after I plug it into the Monte dash harness fuse block. I can swallow the other 2 harness $..but the dash harness is so expensive( Wondering if I should just start cutting and replacing wires to get things working off the og harness.?
Glenns70 is offline  
post #7 of 9 (permalink) Old Apr 14th, 16, 8:28 AM Thread Starter
 
Join Date: Apr 2016
Posts: 5
Re: '70 base Chevelle dash to Monte SS dash?

Done...that was cake...all works..wooooohoooooo
Glenns70 is offline  
post #8 of 9 (permalink) Old Apr 14th, 16, 9:47 AM
Lifetime Premium Member
Dan
 
Join Date: Dec 2009
Location: Wisconsin
Posts: 6,756
Re: '70 base Chevelle dash to Monte SS dash?

Glad you were able to figure it out. Does your Amp gauge work?
RealRed70 is offline  
post #9 of 9 (permalink) Old Apr 14th, 16, 3:16 PM
Ronnie
 
Join Date: Mar 2009
Location: Rio Rancho NM
Posts: 1
Re: '70 base Chevelle dash to Monte SS dash?

Hi RealRed70. I am doing pretty much the same conversation. The reference letters you mention are in directions that came with the dashboard. The picture that is on directions is opposite that of my car, but matches wiring diagram I have. Anyway, do I just splice in the black wires you speak of which came with dash into the DS DT locations? According to wiring diagram, the two locations you mention both go to horn relay. Do they get disconnected or leave attached in addition new black wires? Any help would be greatly appreciated. Thanks.
chevelleron is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevelle Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address. Note, you will be sent a confirmation request to this address.

Email Address:
OR

Log-in









Old Thread Warning
This Thread is more than 1508 days old. It is very likely that it does not need any further discussion and thus bumping it serves no purpose.
If you still feel it is necessary to make a new reply, you can still do so though.

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome