turn signal problems - Chevelle Tech
Electrical & Wiring Troubleshooting electrical problems.

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 7 (permalink) Old Feb 25th, 16, 12:06 PM Thread Starter
Richard
 
Join Date: Feb 2016
Location: Southwestern Vermont
Posts: 4
Send a message via Yahoo to cookie
Question turn signal problems

My turn signals have stopped working1 However when I step on the brakes ,all four bulbs lite up.. I can't find out why?
cookie is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old Feb 25th, 16, 12:18 PM
Lifetime Premium Member
Mark
 
Join Date: Aug 2006
Location: North Baltimore, Oh
Posts: 2,086
Garage
Re: turn signal problems

You probably have a filament burnt on one of your tail lights and laying on the parking light filament causing the backfeed through the front lights.

'69 Chevelle SS ("NOT" ON THE ROAD NOW!
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
)
Engine parts: (Heads, cam & lifters from Lewis Racing Engines)
ZZ502 Short block
AFR 305 CNC 106cc Chambers 8002 springs
Bullet HR ADV Dur 295/297 238/242 @ .050 .680/.650-110 LSA-108 ICL Morel lifters
Holley Avenger MPFI
612HP/594TQ
T-56 Magnum trans with hydraulic McLeod RST
MarkP is offline  
post #3 of 7 (permalink) Old Feb 25th, 16, 12:35 PM
Tech Team
Al
 
Join Date: Dec 2013
Location: Seattle
Posts: 233
Re: turn signal problems

If a brake light /tail light bulb or lamp (as it may be called) is in the socket incorrectly it will give you a back feed and illuminate the dash lamps also.
Al
alhewitt is offline  
 
post #4 of 7 (permalink) Old Feb 25th, 16, 1:38 PM
Tech Team
Bill
 
Join Date: Jan 2016
Location: In the Garage
Posts: 956
Garage
Re: turn signal problems

Step on the brakes and find the one bulb that is not doing the exact same thing that the others are doing. That one is the culprit.

1969 Sport Coupe SS Tribute Cortez Silver 454 400TH
69SS454 is offline  
post #5 of 7 (permalink) Old Feb 25th, 16, 3:04 PM Thread Starter
Richard
 
Join Date: Feb 2016
Location: Southwestern Vermont
Posts: 4
Send a message via Yahoo to cookie
Re: turn signal problems

I have changer all bulbs, but this has not fixed the problem yet!
cookie is offline  
post #6 of 7 (permalink) Old Feb 25th, 16, 3:14 PM
Tech Team
Joe
 
Join Date: Jul 2011
Location: Eaton, Ohio
Posts: 685
Re: turn signal problems

Do your 4 way flashers work? If they do, you need to check the flasher unit located in a harness above the steering column where the column mounts to the dash. There is a clip that the unit fits into on the dash brace but, it's most likely just hanging by the two wires. The flasher unit in the corner of the fuse box is for the 4 way hazard flashers. As a test, just replace it with one from another vehicle. Report what you find.
Toppless72 is offline  
post #7 of 7 (permalink) Old Feb 25th, 16, 9:38 PM Thread Starter
Richard
 
Join Date: Feb 2016
Location: Southwestern Vermont
Posts: 4
Send a message via Yahoo to cookie
Re: turn signal problems

Thanks: for your help! I found the problem to be in the 4 way flasher switch. Some how it got stuck in the on position I got it free, changed the fuse, and everything is working again!
cookie is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevelle Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address. Note, you will be sent a confirmation request to this address.

Email Address:
OR

Log-in









Old Thread Warning
This Thread is more than 1494 days old. It is very likely that it does not need any further discussion and thus bumping it serves no purpose.
If you still feel it is necessary to make a new reply, you can still do so though.

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome