spring ring cables? - Chevelle Tech
Electrical & Wiring Troubleshooting electrical problems.

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 2 (permalink) Old Aug 1st, 03, 1:45 AM Thread Starter
Tech Team
Todd
 
Join Date: Mar 1999
Location: Wi
Posts: 546
Post

I orderd new spring ring battery cables from Year One for my factory original '69 malibu 350 4 speed. The neg cable that they sent is to short. It's not long enough and will not reach the original hook up location. I called them on it and they sent me a new one at no charge but it was the same length. Has anyone ran into this problem?
Luke is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Aug 1st, 03, 4:47 AM
 
Join Date: Apr 1999
Posts: 1,094
Post

Here is a link to another 69 with same problem and includes factory assembly information. May help.
https://www.chevelles.com/cgi-bin/for...;f=31;t=000754
shooter is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevelle Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address. Note, you will be sent a confirmation request to this address.

Email Address:
OR

Log-in









Old Thread Warning
This Thread is more than 5948 days old. It is very likely that it does not need any further discussion and thus bumping it serves no purpose.
If you still feel it is necessary to make a new reply, you can still do so though.

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome