Is my Horn Relay Bad? - Chevelle Tech
Electrical & Wiring Troubleshooting electrical problems.

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 7 (permalink) Old Jul 27th, 03, 6:56 PM Thread Starter
Lifetime Premium Member
Eric
 
Join Date: Apr 2002
Location: Novato, Ca
Posts: 1,389
Send a message via AIM to onick
Post

My horn doesn't work in my 68 chevelle malibu w/ 327. I checked out the horn relay and this is what i found: The horn works on a straight 12v The plugs that are supposed to recieve power do (Black-Red wire, and a Red wire). The Door Open buzzer works. I tried grounding the horn switch male connector (Where black wire going into bundle was connected), and the horn did not sound. Isn't it supposed to? Is the relay bad? Any help would be great. Thanks- Eric

Eric Onick
1968 Chevelle Malibu
Big Block-475ci built by Mark Jones
Tremec TKO-600 5-speed
12 bolt Eaton Posi
TC Member# 2320
onick is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old Jul 27th, 03, 10:30 PM
Team Member
Steamy
 
Join Date: Jul 2003
Location: Here&there, AR
Posts: 6,818
Post

Unplug the small black wire from the relay. Be sure it's the smaller (16ga) wire & not the larger (14ga) wire that goes to the horns. Make a jumper wire, plug it in where you took the black wire out & ground it. The relay should make contact & the hooters should hoot. If this works & it doesn't work when you ground the wire at the horn button, then the problem is in the wiring between the horn button & the relay. Hope this helps.

BL

If you keep on livin', you're gonna get old.
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Good health is merely the slowest possible rate at which one can die.
Good livin' will speed it up, but it's worth it.
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


My Showroom

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Ark68SS is offline  
post #3 of 7 (permalink) Old Jul 27th, 03, 11:13 PM Thread Starter
Lifetime Premium Member
Eric
 
Join Date: Apr 2002
Location: Novato, Ca
Posts: 1,389
Send a message via AIM to onick
Post

thats what i did before. I disconnected the Horn Switch from the relay (the one that goes to the column), and left the wire connected to the actual horn connected to the relay. I then used a jumper cable and inserted it where the Horn Switch connector was. I then grounded it, but nothing happened. sorry if i wasn't clear in my original post. I'm startin' to think it is busted

Eric Onick
1968 Chevelle Malibu
Big Block-475ci built by Mark Jones
Tremec TKO-600 5-speed
12 bolt Eaton Posi
TC Member# 2320
onick is offline  
 
post #4 of 7 (permalink) Old Jul 27th, 03, 11:29 PM
Senior Tech Team
 
Join Date: Nov 2001
Location: Saginaw, Michigan U.S.A.
Posts: 1,883
Post

I have a paper on trouble shooting the 69-82 Corvette horn system. The wiring colors might be different from the GM A-car but I am sure that the relay and horn circuitry are the same. Go to www.corvettefaq.com and look under Steering. Download:

Horn Operation Diagnosis - Rev 07JL03

It should lead you to the correct diagnosis of your problem.
JIML82 is offline  
post #5 of 7 (permalink) Old Jul 27th, 03, 11:30 PM
Team Member
Steamy
 
Join Date: Jul 2003
Location: Here&there, AR
Posts: 6,818
Post

I think you're thinkin' right. Be careful when you replace the relay--the fuse links can be real brittle, so don't bend them or they'll break.
BL

If you keep on livin', you're gonna get old.
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Good health is merely the slowest possible rate at which one can die.
Good livin' will speed it up, but it's worth it.
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


My Showroom

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Ark68SS is offline  
post #6 of 7 (permalink) Old Jul 27th, 03, 11:33 PM Thread Starter
Lifetime Premium Member
Eric
 
Join Date: Apr 2002
Location: Novato, Ca
Posts: 1,389
Send a message via AIM to onick
Post

Thanks for the help. Anyone know of a good place to get a replacement? Year One wanted like $50, that seems a bit steep. Any ideas?

Eric Onick
1968 Chevelle Malibu
Big Block-475ci built by Mark Jones
Tremec TKO-600 5-speed
12 bolt Eaton Posi
TC Member# 2320
onick is offline  
post #7 of 7 (permalink) Old Jul 28th, 03, 12:48 PM
Team Member
Steamy
 
Join Date: Jul 2003
Location: Here&there, AR
Posts: 6,818
Post

Check with NAPA--Part # HR135.

If you keep on livin', you're gonna get old.
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Good health is merely the slowest possible rate at which one can die.
Good livin' will speed it up, but it's worth it.
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


My Showroom

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Ark68SS is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevelle Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address. Note, you will be sent a confirmation request to this address.

Email Address:
OR

Log-in









Old Thread Warning
This Thread is more than 5869 days old. It is very likely that it does not need any further discussion and thus bumping it serves no purpose.
If you still feel it is necessary to make a new reply, you can still do so though.

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome