Did it Blow - Chevelle Tech
Electrical & Wiring Troubleshooting electrical problems.

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 4 (permalink) Old Apr 24th, 19, 6:56 PM Thread Starter
Tech Team
 
Join Date: Jan 2018
Posts: 285
Did it Blow

Well after taking my dash apart to fix my tach that felt like a gazillion times and many hours the amp meter harness plug on the back of the gauge got caught on the dash bracket during installation and shorted out. It blew the fusible link by the voltage regulator which M&H was kind enough to send me a new one. After installing the new one the gauge still doesn't work. I checked that both the black wire and black/white wire are hot at the buckhead so under the hood harness is good to go. I suspect it took out the amp meter but without taking out the dash out which I absolutely will not do again I am hoping there might be something else. I don't have my hopes up but you never know. I didn't smell burning under the dash. Maybe someone will make my day.. Thanks
Billdini is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Apr 24th, 19, 8:37 PM
Lifetime Premium Member
Terry
 
Join Date: Dec 2014
Location: Sacramento, Ca.
Posts: 745
Re: Did it Blow

Was your battery connected at the time? Terry
68-13427 is offline  
post #3 of 4 (permalink) Old Apr 24th, 19, 9:09 PM Thread Starter
Tech Team
 
Join Date: Jan 2018
Posts: 285
Re: Did it Blow

Quote:
Originally Posted by 68-13427 View Post
Was your battery connected at the time? Terry
While I was installing the dash with the new tach the battery was disconnected. If you haven't removed a dash on a 68 with AC you haven't lived. I fired up the engine with my new redline modified OER Roller tach and it worked after months of fighting that issue. I didn't realize until later that the amp meter was just sitting idle and went into troubleshoot mode. First after removing some stuff again I was able to see that the harness plug for the Amp meter was half off and touching the dash frame. I pushed it on but that just goes to show that only the plastic plug protects against a short, its that tight. I found the open fusible link and called M&H for a new replacement. All wiring is new stem to stern on this car. From there I fired up and the gauge just sits there. The gauge operates with two hots on either side (mine doesn't work), one is off the battery and one from the alternator side (both fusible links in front of the battery or by the regulator check out). I don't think there is any other protection to the gauge besides the two fusible links but with gauges the assembly manual only shows wiring for idiot lights.
Billdini is offline  
 
post #4 of 4 (permalink) Old Apr 25th, 19, 12:06 AM
Lifetime Premium Member
Terry
 
Join Date: Dec 2014
Location: Sacramento, Ca.
Posts: 745
Re: Did it Blow

Well Bill , i do have a '68, but no air. I can only imagine what a pain it was, i just did my dash with new harness and it was a pain with the stiff wires. I am not an electrical guru, so i am not the guy to solve this mystery. good luck Terry
68-13427 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevelle Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address. Note, you will be sent a confirmation request to this address.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
What is normal Blow By StevenS Performance 34 Jun 12th, 18 6:40 PM
Should the fan blow my hair back? 70montee Heating & Cooling 12 Sep 29th, 17 10:10 AM
Blow though with FiTech 72much13 EFI 8 Sep 19th, 16 12:32 PM
Blow off valve- diesel vs gas question steve_sutherland Performance 4 Aug 30th, 15 9:43 PM
Help my carbshop holley 750 blow thru carb has overly rich idle VinceS427bb Engine 2 Mar 25th, 14 2:04 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome