Odd tach problem - Chevelle Tech
Electrical & Wiring Troubleshooting electrical problems.

 1Likes
  • 1 Post By Rich-L79
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 5 (permalink) Old Apr 5th, 19, 10:48 PM Thread Starter
Team Member
David
 
Join Date: Dec 2018
Location: Denver
Posts: 20
Garage
Odd tach problem

On a 72 with SS gauges, I have an intermittently working tach. Sometimes it behaves normally. Sometimes not at all. But often at idle the tach will display about negative 200 RPM (the needle rest below zero. Increasing engine speed will increase tach, but always reads lower than it should. When I shut off the ignition, the gauge will jump up to the O mark and stay there. That is the needle will properly point while the engine is off. All other instruments requiring a good ground seem to be okay.

I just replaced the printed circuit board if that might have anything to do with it. BEFORE the replacement I had the same intermittent operation, but had never seen the negative rpm behavior.

Thanks for any help!
davidaugust is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Apr 6th, 19, 11:07 AM
Super Mod
Rich
 
Join Date: Oct 1999
Location: Waverly, NE USA
Posts: 15,405
Garage
Re: Odd tach problem

The electronics in that tach are nearly 50 years old, it is probably just about shot. Probably has a few weak solder joints inside or some of the components are intermittently shorting out. Either replace it or have it rebuilt with new electronics.
NickeyChevelle likes this.
Rich-L79 is online now  
post #3 of 5 (permalink) Old Apr 6th, 19, 1:27 PM
Tech Team
 
Join Date: Jan 2018
Posts: 252
Re: Odd tach problem

Do yourself a favor and send the tachometer to Redline Gauge Works. I got mine back quickly. They can also convert it to a very accurate digital unit. Don't worry you cant tell by looking at it
Billdini is offline  
 
post #4 of 5 (permalink) Old Apr 9th, 19, 9:41 AM
Tech Team
Al
 
Join Date: Dec 2013
Location: Seattle
Posts: 220
Re: Odd tach problem

I also have had good luck with Red Line... Al
alhewitt is offline  
post #5 of 5 (permalink) Old Apr 9th, 19, 9:55 AM Thread Starter
Team Member
David
 
Join Date: Dec 2018
Location: Denver
Posts: 20
Garage
Re: Odd tach problem

Thanks guys. I'm just going to replace the entire unit. This is my daily driver and I will likely have to pull the dash to replace it and I don't want to wait a couple of weeks. I'll wait until I have the replacement and then just swap out.
davidaugust is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevelle Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address. Note, you will be sent a confirmation request to this address.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Roller tach in 68, problem with the HEI? Xaan Electrical & Wiring 3 Oct 16th, 17 6:08 PM
No gas in the carburetor - venting problem? Olle Engine 18 Jul 22nd, 16 2:02 PM
AAW - Wiring engine to coil with white tach and pink ingtn questions? Dnrice Electrical & Wiring 16 May 11th, 15 8:50 PM
Tach Problem After installing MSD Pro-Billet Distributor drtripower Chevelle Tech 14 Oct 19th, 13 11:46 PM
An odd problem with eBay Richvll Bug Hunt 3 Apr 1st, 13 5:06 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome