Alternator/Regulator - Chevelle Tech
Electrical & Wiring Troubleshooting electrical problems.

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 4 (permalink) Old Jan 27th, 19, 9:16 AM Thread Starter
 
Join Date: Jun 2018
Posts: 17
Alternator/Regulator

I just had an new 454/525HP engine installed in my 1970 Chevelle SS. It was in the shop for 3 months. Upon the first start up we found out the alternator was only pushing out 11volts. So I ordered and new Tuff Stuff 100 amp and the shop recommended to also get a new regulator at the same time. I decided I could do this at home. Once I received the items, I installed them without any problems.
I started up the car and I was getting about 14 volts, great. When I went to shut off the car, it wouldn't shut off with the turn of the key, I had to remove the positive battery cable. i double checked everything and it looked ok. Once again i started the car, but after a few seconds I noticed smoke coming from the area of the new regulator. So went to turn off the car, and again it wouldn't shut down without removing the battery cable. I checked the wiring around the regulator area and don't see any burnt wiring. What could wrong?


Thanks ahead for any responses.
Groundhogjr is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Jan 27th, 19, 11:27 AM
Senior Tech Team
Bruce
 
Join Date: Jun 2006
Location: White Bear Lake, a northeast suburb of St. Paul, MinneSNOWta
Posts: 4,690
Garage
Re: Alternator/Regulator

You need to go back to Square One and start the installtion of the wiring harness and the regulator from scratch. Check the P/Ns to make sure you got the parts you want/ordered. Reread the instructions, checking for any special tasks you should have done, etc.

I'd reinstall the old regulator to see if the new regulator is "bad."

Our You Tube Vids:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

NickeyChevelle is offline  
post #3 of 4 (permalink) Old Jan 27th, 19, 11:45 AM
Senior Tech Team
Ed
 
Join Date: Aug 2013
Location: Pittsburgh, PA
Posts: 4,008
Garage
Re: Alternator/Regulator

Also mention what ignition setup you have.

1967 El Camino Malibu - Deepwater Blue
ZZ4 350, FiTech 600 complete!,Roadmaster tank, 700R4, Underdash A/C in progress, JGC Steering, 1990s truck serpentine.
Pioneer4x4 is offline  
 
post #4 of 4 (permalink) Old Jan 27th, 19, 12:37 PM
Tech Team
Jim
 
Join Date: Nov 2016
Location: CT
Posts: 304
Re: Alternator/Regulator

Make sure that the new alternator is designed to work with an external regulator and not a one wire set up.
V1rotate is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevelle Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address. Note, you will be sent a confirmation request to this address.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome