68 dash led bulb upgrade - Chevelle Tech
Electrical & Wiring Troubleshooting electrical problems.

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 4 (permalink) Old May 17th, 18, 9:20 PM Thread Starter
Team Member
johnny
 
Join Date: Mar 2014
Location: georgia
Posts: 385
Garage
68 dash led bulb upgrade

i just replaced dash and turn the power back on and the led work great much brighter on dash,but flasher seems to be malfunctiong,shows green and slowly dims,want flash and no turn signals,should i have replaced with a newer hazard fuse? thanks
454bbss is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old May 18th, 18, 1:00 AM
Senior Tech Team
Vince
 
Join Date: Sep 2006
Location: Los Lunas, NM
Posts: 8,301
Re: 68 dash led bulb upgrade

Quote:
Originally Posted by 454bbss View Post
i just replaced dash and turn the power back on and the led work great much brighter on dash,but flasher seems to be malfunctiong,shows green and slowly dims,want flash and no turn signals,should i have replaced with a newer hazard fuse? thanks
did you go led turn or brake lites also??
a newer ''no load'' flasher should help with issue

68-Malibu 427bbc/t4oo/3.73-12bolt/pro charger f1-r
VinceS427bb is offline  
post #3 of 4 (permalink) Old May 18th, 18, 6:22 AM
Senior Tech Team
Geoff
 
Join Date: Mar 2015
Location: Australia
Posts: 1,865
Re: 68 dash led bulb upgrade

I think Vince nailed it, you need the compatible flasher with LED lights. The original type will not work.
Gtogeoff is offline  
 
post #4 of 4 (permalink) Old May 18th, 18, 4:55 PM
Lifetime Premium Member
Weldon
 
Join Date: Dec 2006
Location: Baytown, Texas
Posts: 614
Re: 68 dash led bulb upgrade

If the turn signals were flashing fast, I would suggest the no-load flasher, but he says "flasher seems to be malfunctioning,shows green and slowly dims,want flash and no turn signals". Not sure what is turning green, but it doesn't sound like a flasher issue.

454BBSS, Do you mean the actual turn signals don't work or that the indicators don't work??

Weldon

64 El Camino
67 Mercury Cougar
66 Chrysler 300
2011 Harley Davidson TriGlide

Team Chevelle #5157
wihaltom is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevelle Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address. Note, you will be sent a confirmation request to this address.

Email Address:
OR

Log-in









Old Thread Warning
This Thread is more than 457 days old. It is very likely that it does not need any further discussion and thus bumping it serves no purpose.
If you still feel it is necessary to make a new reply, you can still do so though.

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome