67 no power to compressor - Chevelle Tech
Electrical & Wiring Troubleshooting electrical problems.

 3Likes
  • 1 Post By pyasher
  • 2 Post By bobm67
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 13 (permalink) Old May 13th, 18, 11:15 AM Thread Starter
Lifetime Premium Member
bob
 
Join Date: Jun 2009
Location: mint hill nc
Posts: 731
67 no power to compressor

I have no power to green wire on compressor. The black ground wire has ground. I cleaned the contacts and checked the inline fuse with orange wire leading out of it. I am not good at a/c wiring, I looked at the wiring diagram and I am lost. Thanks for any help
bobm67 is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old May 13th, 18, 4:49 PM
Boldly procrastrinating
Tom Terrific II
 
Join Date: Oct 1998
Location: Glendale, Az
Posts: 27,910
Garage
Re: 67 no power to compressor

any help here? anybody know where the power to the green wire comes from?

Bob, has this ever worked? Any recent changes on the car?

Tom Terrific or Terrible Tom, depending on the phase of the moon, passing cosmic rays or other factors not fully understood except by my wife.
Tom Mobley is offline  
post #3 of 13 (permalink) Old May 13th, 18, 5:25 PM
Lifetime Premium Member
Al
 
Join Date: Apr 2011
Location: SO CAL...Huntington Beach and Rancho Cucamonga
Posts: 4,340
Garage
Re: 67 no power to compressor

Need an A/C wiring diagram for a 67 chevelle in order to help. Pop one off and post it...Then we can trace it.
DUTCH MAX HEADWORK is offline  
 
post #4 of 13 (permalink) Old May 13th, 18, 6:12 PM
Tech Team
Perry
 
Join Date: Aug 2015
Location: Columbus Ohio
Posts: 32
Re: 67 no power to compressor

I am having the same problem with my 72 - just installed a idle up solenoid on the Q Jet - car originally had a idle stop solenoid - I took power off the green signal wire going to the A/C clutch. I will check my wiring diagram and fuses etc. - will let you know what I find...
pyasher is offline  
post #5 of 13 (permalink) Old May 13th, 18, 6:25 PM
Lifetime Premium Member
Al
 
Join Date: Apr 2011
Location: SO CAL...Huntington Beach and Rancho Cucamonga
Posts: 4,340
Garage
Re: 67 no power to compressor

Quote:
Originally Posted by pyasher View Post
I am having the same problem with my 72 - just installed a idle up solenoid on the Q Jet - car originally had a idle stop solenoid - I took power off the green signal wire going to the A/C clutch. I will check my wiring diagram and fuses etc. - will let you know what I find...
Your vehicle has a completely different electrical lay out. To keep from getting the two cars and wiring confused, please start another thread and we'll see if we can help out.
DUTCH MAX HEADWORK is offline  
post #6 of 13 (permalink) Old May 13th, 18, 7:43 PM
Gold Member
Joe
 
Join Date: Aug 1998
Location: Lincoln, NE
Posts: 4,469
Re: 67 no power to compressor

These cars have a dedicated compressor switch. It's sort of a spring loaded snap-action reed switch on the later years, where the early years can have a bracket mounted plunger switch.

The contacts can wear out from the internal arcing over time.

-If you don't stand for something, you'll fall for anything.
Coppertop is offline  
post #7 of 13 (permalink) Old May 14th, 18, 6:50 AM Thread Starter
Lifetime Premium Member
bob
 
Join Date: Jun 2009
Location: mint hill nc
Posts: 731
Re: 67 no power to compressor

Quote:
Originally Posted by Coppertop View Post
These cars have a dedicated compressor switch. It's sort of a spring loaded snap-action reed switch on the later years, where the early years can have a bracket mounted plunger switch.

The contacts can wear out from the internal arcing over time.
Were is the switch located, and is there a easy way to test it. The A/C was rebuilt in 2001 and still has R-12. It's worked every year all I have to do is clean the connects at the compressor but not this year. If it was low on R-12 would it have power to the green wire on the compressor.
bobm67 is offline  
post #8 of 13 (permalink) Old May 14th, 18, 11:06 AM
Lifetime Premium Member
Andy
 
Join Date: Apr 2010
Location: West Palm Florida
Posts: 7,064
Re: 67 no power to compressor

I did ac on a 67 GTO last year and it was a switch on top of the inside heater case actuated by the mode door cable.

Couple of junkers and a few clunkers.
Andy's Auto Repair is offline  
post #9 of 13 (permalink) Old May 14th, 18, 2:50 PM Thread Starter
Lifetime Premium Member
bob
 
Join Date: Jun 2009
Location: mint hill nc
Posts: 731
Re: 67 no power to compressor

Quote:
Originally Posted by Andy's Auto Repair View Post
I did ac on a 67 GTO last year and it was a switch on top of the inside heater case actuated by the mode door cable.
Was it adjustment on the A/C cable or bad switch. It feels like the cable moves something when you move all the way to the left. Thank you
bobm67 is offline  
post #10 of 13 (permalink) Old May 14th, 18, 3:30 PM
Lifetime Premium Member
Andy
 
Join Date: Apr 2010
Location: West Palm Florida
Posts: 7,064
Re: 67 no power to compressor

Quote:
Originally Posted by bobm67 View Post
Was it adjustment on the A/C cable or bad switch. It feels like the cable moves something when you move all the way to the left. Thank you
It wound up being a bad switch. I used an activation switch from a nitrous kit and it bolted right in.

Couple of junkers and a few clunkers.
Andy's Auto Repair is offline  
post #11 of 13 (permalink) Old May 16th, 18, 6:26 AM
Tech Team
Perry
 
Join Date: Aug 2015
Location: Columbus Ohio
Posts: 32
Re: 67 no power to compressor

Quote:
Originally Posted by DUTCH MAX HEADWORK View Post
Your vehicle has a completely different electrical lay out. To keep from getting the two cars and wiring confused, please start another thread and we'll see if we can help out.

Thanks Dutch - it was the thermal switch on the drivers side by the compressor - jumped it out and 12 V are back. According to all I talked to it is a common problem and most folks just jump it. I have ordered a reproduction one off e bay.
DUTCH MAX HEADWORK likes this.
pyasher is offline  
post #12 of 13 (permalink) Old May 17th, 18, 10:10 AM Thread Starter
Lifetime Premium Member
bob
 
Join Date: Jun 2009
Location: mint hill nc
Posts: 731
Re: 67 no power to compressor

Thanks Andy for you help. It was dirty terminals on the switch on top of heater box behind glove box.
LeoP and Andy's Auto Repair like this.
bobm67 is offline  
post #13 of 13 (permalink) Old May 20th, 18, 10:59 PM
Senior Tech Team
Kev
 
Join Date: Aug 2007
Location: Texas
Posts: 1,757
Re: 67 no power to compressor

Wiring is wiring until it gets hacked over the lifespan of the vehicle.
Pretty sure the insulation on the wire running the (pick something) has a color, it's in a harness, and the harness has only a few ends. Find the same color wire exiting the harness, and follow. Repeat.
66sc is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevelle Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address. Note, you will be sent a confirmation request to this address.

Email Address:
OR

Log-in









Old Thread Warning
This Thread is more than 393 days old. It is very likely that it does not need any further discussion and thus bumping it serves no purpose.
If you still feel it is necessary to make a new reply, you can still do so though.

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome