1997 Chevy S10, A/C not working - Chevelle Tech
Misc (NON CHEVELLE AUTOMOTIVE TECH) This section is for the Non-Chevelle Related automotive questions/answers or discussion.

 1Likes
  • 1 Post By Dean
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 2 (permalink) Old Jun 24th, 19, 4:53 PM Thread Starter
Lifetime Premium Member
Tony
 
Join Date: Apr 1999
Location: Folsom, CA
Posts: 17,021
Garage
1997 Chevy S10, A/C not working

Where should I start?

Thinking I should get a pressure gauge and see if there is anything in the system. If low, then add some (with dye)... Or, can I just quickly depress the schrader valve with a key/screwdriver to see if there is any pressure?

But if its empty, should I add some dye first (before evac?), to find the leak? Or is that dangerous without evac (high pressure head?)...


I ordered new o-ring kit and a new rec/dryer in anticipation. of replacing something...


I had a cracked line replaced a few years ago (four years?), but the A/C quit working last year, but I put it off. I only put 100-200 miles per year, but summers are brutally hot...

Thanks

Once you go RAT, you never go back...
TC #1366

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Sold

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Sold
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
&
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
1966_L78 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Jun 24th, 19, 5:05 PM
Gold Founding Member
Administrator
 
Join Date: Aug 1998
Location: near Kansas City
Posts: 61,178
Garage
Re: 1997 Chevy S10, A/C not working

Yes, you need a set of gauges.

IF there is zero pressure in the system it needs to be evacuated BUT I would add a little refrigerant to pressurize the system and check for leaks first.

IF there is some pressure in the system but low, check for leaks first.

Those compressors are bad about leaking where the front and rear end bells are sealed to the center body of the compressors.

Of course you could just charge it up every so often like a lot of people do, depending on how fast it leaks down.
LeoP likes this.

.
.
.
.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Dean is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevelle Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address. Note, you will be sent a confirmation request to this address.

Email Address:
OR

Log-in













Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome