2013 Traverse - Chevelle Tech
Misc (NON CHEVELLE AUTOMOTIVE TECH) This section is for the Non-Chevelle Related automotive questions/answers or discussion.

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 1 (permalink) Old May 13th, 19, 3:41 PM Thread Starter
jac
Lifetime Premium Member
 
Join Date: Feb 2000
Location: union nj
Posts: 1,572
2013 Traverse

my son's 2013 traverse coolant was low a few days ago, added Dexcool and now level is OK . The problem is that motor says hot and AC turned off.Message comes on and off.Temp goes from 210 to 160 .

Could it be a sensor and how to replace Thanks Joe

70ss nassau blue
jac is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevelle Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address. Note, you will be sent a confirmation request to this address.

Email Address:
OR

Log-in













Similar Threads
Thread Thread Starter Forum Replies Last Post
All-GM Oktoberfest @ Silver Springs Theme Park in Ocala, FL for 2013 [email protected] Team Chevelle Cruiz-ins 21 May 17th, 13 9:42 AM
Alternative for Chevell-abration 2013. Alan F Team Chevelle Cruiz-ins 36 May 15th, 13 9:16 PM
April 2013 Cruise-In / Car Show jasonc1974 Team Chevelle Cruiz-ins 1 Mar 5th, 13 12:12 PM
2013 MCACN`s 1973 Buick Stage1 Display Postsedan Team Chevelle Cruiz-ins 1 Nov 22nd, 12 8:06 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome