Pump and/or gearbox issues.... - Chevelle Tech
Brakes, Suspension & Steering Conversion questions & more.

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 2 (permalink) Old Aug 11th, 19, 3:25 AM Thread Starter
Lifetime Premium Member
Tony G
 
Join Date: Feb 2014
Location: San Diego, CA
Posts: 291
Question Pump and/or gearbox issues....

I installed a March Performance Sport Track front drive 6 groove pulley setup for my '64 SB without AC. The kit comes with a new later model Saginaw canister type key way pump. I have a rebuilt Lares 970 gearbox that I did not have issues with with the old pump. After install of the pulley kit I did a bleed of the system even though I only changed the pump. I completed about 25-30 lock to lock turns of the wheel noting no air bubbles or change in fluid level. I used an O'Reilly brand power steering fluid that says good for all systems. The belt is tight and was re-tightened after a few hours of running.



The problem: While running at about almost near lock on either side, the pump pulley is fighting and causing the belt to slip. I'm watching as someone turns the wheel for me that the pump pulley is laboring to the point it's causing the belt to slip and squeal. The steering wheel seems to bind or turn hard as it squeals. The belt is new, tight and not glazed so I'm leaning towards possibly the Lares gearbox. I contacted Lares and they said it being a rebuild might have some internal bushing that's bad causing an air gap.



I've never heard of this and wonder if anyone else would consider the gearbox as the problem or could the brand new Saginaw pump supplied with the kit have issues. I'm leaning towards the box as being the problem.

'64 SS Coupe, 4 spd Muncie M-20, 12 bolt 3:42, 350sb 9.75:1, Edelbrock RPM top kit with roller cam, EB 600cfm carb.
Weekend driver....
Weekends need to be 4 days long every week.....
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Antalamo is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Aug 11th, 19, 8:27 AM
Boldly procrastrinating
Tom Terrific II
 
Join Date: Oct 1998
Location: Glendale, Az
Posts: 28,300
Garage
Re: Pump and/or gearbox issues....

Sounds likke a bad/defective pump to me. most of these rebuilt pumps are built in Mexico by people who have never owned, driven or worked on a car.. It's very easy to assemble the outlet valve and pressure relief incorrectly. If the pressure relief don't work right there will be very high pressure when the box goes to full lock, either direction. It's possible under these circumstances to blow the pressure line between the pump and box.

PM me if you it fixed. I'm in the Phx area shipping is fast.

Tom Terrific or Terrible Tom, depending on the phase of the moon, passing cosmic rays or other factors not fully understood except by my wife.
Tom Mobley is offline  
Sponsored Links
Advertisement
 
Reply

Tags
lares , march performance , power steering pump , squeal , steering gearbox

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevelle Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address. Note, you will be sent a confirmation request to this address.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome