70 396/350 stock running rich - Chevelle Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 4 (permalink) Old Oct 16th, 15, 3:46 PM Thread Starter
Don
 
Join Date: Sep 2015
Location: Sykesville Md
Posts: 11
70 396/350 stock running rich

hello everyone,
I could use your your help,
I bought 70 chevelle 396 /350 rebuilt but completely stock
the car was running great a couple of weeks ago except when trying to start the car 30 minutes after shutting it off.
the car started and ran fine when cold,
so, I thought I should have the carb rebuilt and sent it to the carb shop in NJ
I got the carb back and bolted it on and the car is running so rich it burns your eyes. I have checked the vacuum connections and they are fine.
the car ran fine before I took the carb off, and I have changed nothing since backing it into the garage,
could the rebuilt carb be the culprit?
should I have the carb checked again ?
I am definitely puzzled as I was told the carb was flow benched etc.
help please,
thanks
z10pacecar is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Oct 16th, 15, 3:50 PM
Lifetime Premium Member
 
Join Date: May 1999
Location: Under the hood of some musclecar
Posts: 28,295
Re: 70 396/350 stock running rich

I am guessing this is a Quadrajet.
It is possible the choke might be sticking. Make sure it is wide open when warmed up.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.




To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
mr 4 speed is offline  
post #3 of 4 (permalink) Old Oct 16th, 15, 5:52 PM Thread Starter
Don
 
Join Date: Sep 2015
Location: Sykesville Md
Posts: 11
Re: 70 396/350 stock running rich

hi Mr. 4 Speed ,
yes I observed the choke while the air cleaner was off,
working fine,
thanks
z10pacecar is offline  
 
post #4 of 4 (permalink) Old Oct 16th, 15, 5:53 PM Thread Starter
Don
 
Join Date: Sep 2015
Location: Sykesville Md
Posts: 11
Re: 70 396/350 stock running rich

sorry, yes it's a stock quadrajet I just had rebuilt by Custom Carb in NJ
z10pacecar is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevelle Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address. Note, you will be sent a confirmation request to this address.

Email Address:
OR

Log-in









Old Thread Warning
This Thread is more than 1615 days old. It is very likely that it does not need any further discussion and thus bumping it serves no purpose.
If you still feel it is necessary to make a new reply, you can still do so though.




Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome