Holley 600 Issues - Chevelle Tech
Troubleshooting Diagnosing problems done here.

 2Likes
  • 2 Post By Jimmy Allen
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 8 (permalink) Old Oct 21st, 18, 11:09 PM Thread Starter
Jimmy
 
Join Date: Oct 2018
Location: San Diego
Posts: 17
Holley 600 Issues

Okay hang on with me if this has been brought up already. I'm new to this. I have basic mechanical sense.

First issue: My car has a Holley Classic 600, and I've been experiencing leaks that appear to be coming from the choke shaft after I turn the motor off. Today I rebuilt the carburetor. while I had it apart, I discovered the inside of my carburetor appears to be"flaking" and a Google search showed that this was a common problem with a bunch of Holleys probably made sometime between 2001 and 2002. Is this carburetor still usable?

Second issue: I have not been able to stop the leak coming from what appears to be the choke shaft. I have already gone through the carb and the floats are not stuck. My buddy says its the shaft and the carb is done for. At this point is it even worth it to try and salvage this carburetor with these two issues or should I just replace it?

Thanks,
Jimmy
Attached Thumbnails
Click image for larger version

Name:	IMG_4001.jpg
Views:	46
Size:	105.3 KB
ID:	577252  

Last edited by Jimmy Allen; Oct 21st, 18 at 11:17 PM. Reason: Add photo
Jimmy Allen is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old Oct 21st, 18, 11:31 PM
Senior Tech Team
 
Join Date: Feb 2000
Location: SF Bay Area
Posts: 10,060
Re: Holley 600 Issues

That area circled is a throttle shaft, but from that angle looks to be the secondary side. Do you have a picture of the flaking. Can you show a picture of the air horn, it will show the part number as well as the date manufactured. If there is lateral movement in the throttle shafts itís probably not worth fixing.

Steve R
Steve R is offline  
post #3 of 8 (permalink) Old Oct 22nd, 18, 6:14 AM
Senior Tech Team
Geoff
 
Join Date: Mar 2015
Location: Australia
Posts: 1,865
Re: Holley 600 Issues

Put an Edelbrock on it...
Gtogeoff is offline  
 
post #4 of 8 (permalink) Old Oct 22nd, 18, 9:42 AM
Senior Tech Team
Eric
 
Join Date: Aug 2011
Location: Poteau, Ok
Posts: 4,580
Re: Holley 600 Issues

Check your float levels for the leaking problem.

Your just jealous because you can't hear the voices!

1967 Olds Cutlass 468 BBC/T400
1963 Plymouth Fury 440/Torqueflite
2007 Ford Mustang GT (momma's car)
oldcutlass is offline  
post #5 of 8 (permalink) Old Oct 22nd, 18, 1:47 PM
Tech Team
tom
 
Join Date: Jan 2007
Location: Chicago
Posts: 97
Re: Holley 600 Issues

call Holley and tell them you may have one of those defective carbs. They may send you a new or refurbished one. that's how I got mine.
tm
tm66 is offline  
post #6 of 8 (permalink) Old Oct 22nd, 18, 2:38 PM
Senior Tech Team
 
Join Date: Feb 2000
Location: SF Bay Area
Posts: 10,060
Re: Holley 600 Issues

Quote:
Originally Posted by tm66 View Post
call Holley and tell them you may have one of those defective carbs. They may send you a new or refurbished one. that's how I got mine.
tm
Itís nearly 20 years old, itís out of warranty. Besides he wasnít the original purchaser. How old was your when they replaced it?

Steve R
Steve R is offline  
post #7 of 8 (permalink) Old Oct 23rd, 18, 1:34 PM
Tech Team
tom
 
Join Date: Jan 2007
Location: Chicago
Posts: 97
Re: Holley 600 Issues

Bought a refurbished one from a speed shop about 10 years ago. Car ran worse so started investigating and saw the flakes. Called Holley to see what they thought and after giving them the numbers (don't remember which ones) they came back and just said "We're sending you a new one. Please end this one back to us."
You can't strike out if you don't go to bat.
tm
tm66 is offline  
post #8 of 8 (permalink) Old Oct 27th, 18, 3:06 AM Thread Starter
Jimmy
 
Join Date: Oct 2018
Location: San Diego
Posts: 17
Re: Holley 600 Issues

Yeah all kinds of lateral play so I picked up a new one and everything is solved.
Steve R and LeoP like this.
Jimmy Allen is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevelle Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address. Note, you will be sent a confirmation request to this address.

Email Address:
OR

Log-in









Old Thread Warning
This Thread is more than 479 days old. It is very likely that it does not need any further discussion and thus bumping it serves no purpose.
If you still feel it is necessary to make a new reply, you can still do so though.

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome