Chevelle Tech - View Single Post - Upset beyond belief
View Single Post
post #19 of (permalink) Old Aug 16th, 19, 1:39 PM
Pioneer4x4
Senior Tech Team
Ed
 
Join Date: Aug 2013
Location: Pittsburgh, PA
Posts: 4,044
Garage
Re: Upset beyond belief

Quote:
Originally Posted by Busted Knuckles View Post
So where the hell are all of my 10mm sockets? I've used magnets and grabbers to no avail.

O'Reilly's has a package of 8 different 10mm sockets, everything from very deep to small with a couple of swivels thrown in. Now that I have an abundance of 'em, I don't often need one...
I know where I almost lost one (well a 3/8")!
Putting the O2 sensor in my drivers side down pipe for my FiTech setup. I drilled the hole, and was mounting the clamp on bung with 2 large stainless hose clamps. I was using a nut driver handle and socket on them instead of fighting to keep a screwdriver in the slot.

And it was slightly off of being lined up good, so I used the nut driver handle in the hole in the bung, and exhaust pipe to waggle it around, and pop, off came the socket into the exhaust pipe. I was using a tiny reach magnet fighting the steel pipe it was in, and finally got it. It actually went the other way and was up the slope of the pipe about 2" towards the manifold. Next attempt would have been the shop vac over the hole. That is also good for getting lost parts.

1967 El Camino Malibu - Deepwater Blue
ZZ4 350, FiTech 600 complete!,Roadmaster tank, 700R4, Underdash A/C in progress, JGC Steering, 1990s truck serpentine.
Pioneer4x4 is offline  
 
 
For the best viewing experience please update your browser to Google Chrome