Chevelle Tech - View Single Post - After 17 years on this site... 1968 Chevelle 300 2dr Post
View Single Post
post #227 of (permalink) Old Jun 17th, 19, 2:34 AM Thread Starter
RAMBO
Lifetime Premium Member
Ben
 
Join Date: Apr 2000
Location: Snohomish, WA
Posts: 7,424
Garage
Re: After 17 years on this site... 1968 Chevelle 300 2dr Post

Quote:
Originally Posted by 68-13427 View Post
I believe there were 2 different heater controls, early production and late production. The reason i say this is because my '68 300 deluxe was built on the last shift of the last day of '68 production for the Fremont, Ca. plant. My heater controls have a lighted face, provision for the bulb and the wiring to power the bulb. I bought a set of heater controls at a swap meet just for the cables, this set up did not have the provisions for a bulb. I don't know when the swap meet part was built, but as we know, G.M. did weird stuff back then. Just my opinion , not proven fact. Terry
Interesting. Mine had the provision for the bulb (round opening on the RH side of the controls) but no trace of a wire. I even searched the harness for signs of a stub). Of course its possible that the control could have been swapped at some time, based on some minor changes I found I do suspect the car had been ""restored"" sometime around 20 years ago or so, long before it was hotrodded, so anything is possible

Ben R.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
-
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
RAMBO is offline  
 
 
For the best viewing experience please update your browser to Google Chrome