Chevelle Tech - View Single Post - Need Help Diagnosing Popping
View Single Post
post #4 of (permalink) Old Apr 15th, 19, 11:18 AM Thread Starter
mdelgado
Tech Team
Mike
 
Join Date: Jun 2013
Location: Boston
Posts: 729
Re: Need Help Diagnosing Popping

Quote:
Originally Posted by JF74chevelle View Post
Did you notice if one of the headers is colder than the rest? Maybe you should recheck the valves since you only drove it once awhile ago.
Unfortunately I broke my infrared temp gun. I just ordered a new one.



Quote:
Originally Posted by BillK View Post
Mike,

Do you know anyone at a modern auto repair shop that could hook up a scope to it and take a look ? That would at least tell you if it is an ignition issue or something else. If it was running fine before you parked it then I doubt it has anything to do with valve adjustment. If it is a hydraulic roller you would have to be way off to make it pop.

I don't know anyone at a shop and I think around here, if they can't hook a scan tool up to it, they probably wouldn't know.

It's a nice rainy dark day here in New England, maybe tonight i'll check for moisture in the cap or look for some arching?

67 Chevelle 454, M21
Gen IV 454 (out of C30 ), 390 heads 1.88/2.19 valves by Vortecpro, with ISKY Hyd Roller cam (at 050 218 int./228 exh, lift 530 int./552 exh.), RPM performer intake, Fitech 600HP, Dougs headers, and M21, Gear Vendors OD, 3.73's, UMI Suspension, Viking coilovers.
mdelgado is offline  
 
 
For the best viewing experience please update your browser to Google Chrome