HEI distributor.... NO FIRE - Chevelle Tech
Chevelle Tech join team chevelle as a supporting member  
Chevelle Parts at SS396.com      
GROUND UP & SS396.com         
Official Sponsor of Team Chevelle
     

Auto Insurance

Chevelles.com is the premier Chevrolet Chevelle Forum on the internet. Registered Users do not see the above ads.
Troubleshooting Diagnosing problems done here.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old Oct 14th, 10, 9:40 AM
Rusty Bucket Rusty Bucket is offline
Tech Team
 
Join Date: Jan 2001
Location: Fla.'s Spacecoast
Posts: 138
Default HEI distributor.... NO FIRE

My '72 Jimmy 2wd.. (350/350trans.) wouldn't run. I took a plug wire off a plug, stuck an old plug on the wire, grounded the plug body and turned the engine .. NO FIRE. I ran a jumper from the pos. battery post to the BAT connection on the HEI... NO FIRE. I had a brand new ProComp HEI I'd bought off Craigslist cheap awhile back, so I put it in...NO FIRE. I hooked the old cruddy HEI I'd removed to the battery, used 2 old plugs and wires, grounded the HEI's body and spun the gear with my fingers... SNAP! SNAP!, I could see and hear it firing 'em GOOD. Took the new ProComp back out, hooked it up the same way to test it and it fires the test plugs even better. I put it back in, hooked it up ...NO FIRE. The rotor turns when it's in the engine, and the distributor body is grounded according to my 12v tester. WHY WON'T THIS THING FIRE IN THE VEHICLE!!? I'm about out of ideas. Don't have a Chevelle right now but the amount of Chevy knowledge on this site has ALWAYS been GREAT. Somebody bail me out.. PLEASE!!
__________________
If it ain't broke.....just gimmie a minute

'70 Nova, 406" SB, 'glide/brake, tubbed, ladder bar/coil overs. 9" Ford
'69 Nova 350/4spd.
'71 GMC short/step, 350, 700r, Vintage A/C, ps,pb.
'67 C10 short/step
'66 Belvedere City of Miami cop car clone
'72 2wd Blazer 454, TKO 500 O.D.
...no CHEVELLE right now ;<(
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old Oct 14th, 10, 10:24 AM
zombie1969 zombie1969 is offline
Senior Tech Team
AKA Zombietroll
 
Join Date: Jun 2010
Location: Enfield CT.
Posts: 2,476
Default Re: HEI distributor.... NO FIRE

72 would have points originally so make sure you have a full 12volts and the rotor turns when the engine is cranked.Other than that make sure you have a good engine ground.Nothing wrong with running a GM unit also because they are good.
__________________
64 Chevelle..5867.. FI SB406..700R4..12 Bolt..New door skins and full quarters...
My 64 chevelle SS convertible: http://youtu.be/iwF30uWmvD0
http://www.chevelles.com/forums/showthread.php?t=326530
http://www.chevelles.com/forums/showthread.php?t=334859
Reply With Quote Quick reply to this message
  #3  
Old Oct 14th, 10, 11:20 AM
Rusty Bucket Rusty Bucket is offline
Tech Team
 
Join Date: Jan 2001
Location: Fla.'s Spacecoast
Posts: 138
Default Re: HEI distributor.... NO FIRE

Thanks Gary, There's no resistor in the ignition circuit any more, straight 12v. I've tried it hotwired from the pos. battery to the HEI.... rotor turns.... gonna try to gound it a little MORE with my jumper cables.
__________________
If it ain't broke.....just gimmie a minute

'70 Nova, 406" SB, 'glide/brake, tubbed, ladder bar/coil overs. 9" Ford
'69 Nova 350/4spd.
'71 GMC short/step, 350, 700r, Vintage A/C, ps,pb.
'67 C10 short/step
'66 Belvedere City of Miami cop car clone
'72 2wd Blazer 454, TKO 500 O.D.
...no CHEVELLE right now ;<(
Reply With Quote Quick reply to this message
  #4  
Old Oct 14th, 10, 8:51 PM
Everett#2390 Everett#2390 is offline
Tech Team
everettwn@aol.c
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 119
Default Re: HEI distributor.... NO FIRE

Either the module is bad or the pick-up coil is open, or items inside are unplugged.
__________________
Give a man a rescued dog for the health of his soul.
Other stuff: http://www.flickr.com/photos/everettwn68 www.firstgens.com
Reply With Quote Quick reply to this message
  #5  
Old Oct 14th, 10, 10:36 PM
tristatechevelle tristatechevelle is offline
Tech Team
Dave
 
Join Date: May 2009
Location: SW Wisconsin
Posts: 244
Default Re: HEI distributor.... NO FIRE

I was going to say module also. Had it happen once. I've carried and extra ever since. lol
Reply With Quote Quick reply to this message
  #6  
Old Oct 14th, 10, 11:05 PM
Schurkey Schurkey is offline
Gold Founding Member
 
Join Date: Aug 1998
Location: the Seasonally Frozen Wastelands
Posts: 9,494
Default Re: HEI distributor.... NO FIRE

http://www.chevelles.com/techref/ftecref5.html
Reply With Quote Quick reply to this message
  #7  
Old Oct 15th, 10, 9:44 PM
Rusty Bucket Rusty Bucket is offline
Tech Team
 
Join Date: Jan 2001
Location: Fla.'s Spacecoast
Posts: 138
Default Re: HEI distributor.... NO FIRE

Schurkey, Thank you! GREAT tech. info. I think I have everything but the spark tester. Busy tomorow but look forward to working on it Sun. Anything bad about the Procomp(it's new) or is an old used GM better to work with? BOTH of 'em worked out of the veh.
__________________
If it ain't broke.....just gimmie a minute

'70 Nova, 406" SB, 'glide/brake, tubbed, ladder bar/coil overs. 9" Ford
'69 Nova 350/4spd.
'71 GMC short/step, 350, 700r, Vintage A/C, ps,pb.
'67 C10 short/step
'66 Belvedere City of Miami cop car clone
'72 2wd Blazer 454, TKO 500 O.D.
...no CHEVELLE right now ;<(
Reply With Quote Quick reply to this message
  #8  
Old Oct 15th, 10, 10:58 PM
Schurkey Schurkey is offline
Gold Founding Member
 
Join Date: Aug 1998
Location: the Seasonally Frozen Wastelands
Posts: 9,494
Default Re: HEI distributor.... NO FIRE

I would rather have a "used but usable" Delco HEI than a brand-new Communist knock-off of an HEI.

At least you can be assured that the Delco was built right to begin with.
Reply With Quote Quick reply to this message
  #9  
Old Oct 15th, 10, 11:44 PM
Rusty Bucket Rusty Bucket is offline
Tech Team
 
Join Date: Jan 2001
Location: Fla.'s Spacecoast
Posts: 138
Default Re: HEI distributor.... NO FIRE

I've got three GM candidates to choose from.
__________________
If it ain't broke.....just gimmie a minute

'70 Nova, 406" SB, 'glide/brake, tubbed, ladder bar/coil overs. 9" Ford
'69 Nova 350/4spd.
'71 GMC short/step, 350, 700r, Vintage A/C, ps,pb.
'67 C10 short/step
'66 Belvedere City of Miami cop car clone
'72 2wd Blazer 454, TKO 500 O.D.
...no CHEVELLE right now ;<(
Reply With Quote Quick reply to this message
  #10  
Old Oct 19th, 10, 12:08 AM
Rusty Bucket Rusty Bucket is offline
Tech Team
 
Join Date: Jan 2001
Location: Fla.'s Spacecoast
Posts: 138
Default Re: HEI distributor.... NO FIRE

I took the ProComp dist. out and hooked it up to test it..NO FIRE. I tested the best looking of the 3 other distributors and it fired good so I dropped it in. My neighbor cranked it for me while I watched under the hood in case I needed to move the dist. I could tell it was firing 'cause it was bucking against the starter. Before I could retard the timing I got sparks and smoke from the end of the battery cable... I think somebody had soldered an end on and it burned it off.............. had to drop the starter out to connect the new cable to the solenoid 'cause of the headers. Put it back together and the last drama was when I turned the key and it wouldn't turn on the starter.... CRAPPP!!!!, stomped around for awhile cussin'. Finally thought to wiggle the shift lever, it turned a couple of turns and started right up.
Thanks for the suggestions and information........ lots of very knowledge and good helpful people on this site.
__________________
If it ain't broke.....just gimmie a minute

'70 Nova, 406" SB, 'glide/brake, tubbed, ladder bar/coil overs. 9" Ford
'69 Nova 350/4spd.
'71 GMC short/step, 350, 700r, Vintage A/C, ps,pb.
'67 C10 short/step
'66 Belvedere City of Miami cop car clone
'72 2wd Blazer 454, TKO 500 O.D.
...no CHEVELLE right now ;<(
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply
Chevelle Tech > Mechanical > Troubleshooting      Current Topic: HEI distributor.... NO FIRE
Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevelle Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address. Note, you will be sent a confirmation request to this address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 4:58 AM.


Is there a site like this for?    El Caminos Camaros Novas Impalas GTO Chevy Punch All Chevys

2009 Team Chevelle - AutoForums