Chevelle Tech - View Profile: andrewb70

andrewb70 andrewb70 is offline

Senior Tech Team

  Visitor Messages

Showing Visitor Messages 1 to 4 of 4
  1. bumrussh
    Oct 14th, 13 1:18 AM - permalink
    bumrussh
    hoping you could give some info on the weight jacks you installed. im trying to put in the same set up as you but having a hard time puting a parts list together. any help would be great. thanks in advance.
  2. fastlane666
    Aug 11th, 13 3:13 PM - permalink
    fastlane666
    Hi Andrew my name is Greg. I've been reading through your thread on the driveline vibration issue and I too have been chasing a vibration at highway speed. I have replaced every thing behind the engine and is still there. could you possibly share with me in lay-person terms what the angles should be. I just installed umi adjustable upper control arms and I want to try and adjust the pinion to see if it helps. here is my combination; 66 chevelle 408 cu.in sbc, solid mounted quick time bell housing tko 600 modified by Kiesler. custom drive shaft with 1350 u-joints. 12 bolt rear with 3:55 gears and 275/50-15 mt drag radials. I have broken many transmissions over time chasing this issue along with drive shafts and pinion bearings. as i'm sure you know i'm beginning to lose my sanity over this issue. thanks for any information you have to share.
  3. andrewb70
    Feb 9th, 09 10:50 PM - permalink
    andrewb70
    Thanks for the compliment. The end result is pretty amazing. It is nothing like driving an old car. Much more like driving a new modern vehicle.
  4. wendon65
    Feb 6th, 09 11:14 AM - permalink
    wendon65
    I checked out you build thread on the GTO. Very nice job you did! A lot of time and money went into that project. How do you like you end results?

  About Me

  Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: Jun 23rd, 17 2:18 PM
  • Join Date: Apr 19th, 01
  • Referrals: 0

  Mentions

No results to display...

  Quotes

Jun 23rd, 17
2:18 PM - andrewb70 quoted chevymike in post Re: Tired of listening to that Walbro 255l/hr pump scream?
I recall not long ago that Wal...
2:09 PM - andrewb70 quoted Alan F in post Re: Lost power, fluxing RPM at idle, super charged
It sounds like you have a l...
1:58 PM - andrewb70 quoted WHT/73 in post Re: Tired of listening to that Walbro 255l/hr pump scream?
I don't hear my 400lph walb...
11:48 AM - andrewb70 quoted Schwany in post Re: Tired of listening to that Walbro 255l/hr pump scream?
I run a Walbro 255lph 60psi ...
Jun 17th, 17
12:53 PM - andrewb70 quoted Tegguy in post Re: EFI Conversion?
I watched the install video...
12:44 PM - andrewb70 quoted Jebchevelle in post Re: Sniper Install
Had not seen the temp sensor thi...
Jun 3rd, 17
3:46 PM - andrewb70 quoted Nick_R_23 in post Re: Anyone drive an unrestored car? Lets see it!
I recognize you from LS1tech. ...
3:21 PM - Nick_R_23 quoted andrewb70 in post Re: Anyone drive an unrestored car? Lets see it!
I daily drive my Cougar...It l...
2:04 PM - andrewb70 quoted Clint44 in post Re: I'm just about ready to pull the trigger on these wheels.
Falken makes a couple of tir...
May 27th, 17
3:10 PM - andrewb70 quoted deserttaco in post Re: Should I take the heads off??? LS2
Even if Grinding dust got in th...
2:59 PM - T_R quoted andrewb70 in post Re: Aluminum radiators and electric fans
I would not have one fan runni...
12:57 PM - andrewb70 quoted T_R in post Re: Aluminum radiators and electric fans
.... I think I might wir...
5:13 AM - BlackoutSteve quoted andrewb70 in post Re: Aluminum radiators and electric fans
http://www.youtube.com/watch?v...
May 26th, 17
12:06 PM - andrewb70 quoted zombie1969 in post Re: Should I take the heads off??? LS2
I'd blow shop air in the spark ...
May 24th, 17
8:12 PM - WakkoWarner quoted andrewb70 in post Re: $2.8 Million Icona Vulcano - Exceedingly Overpriced...
Titanium is nifty and all, but...
5:41 PM - andrewb70 quoted ToocoolZ28 in post Re: Tremec reverse problem
Thanks Andrew, no inspection co...
1:36 PM - ToocoolZ28 quoted andrewb70 in post Re: Tremec reverse problem
I suspect the clutch is not fu...
May 23rd, 17
2:13 PM - andrewb70 quoted Jeff65SS in post Re: DBW Pedal assembly
How well did it fit the A Bod...
9:50 AM - andrewb70 quoted Jeff65SS in post Re: DBW Pedal assembly
Andrew, did you once suggest ...
May 22nd, 17
10:42 PM - andrewb70 quoted Msdrill in post Re: DBW Pedal assembly
From an article I read, cpp ...
For the best viewing experience please update your browser to Google Chrome