TCS L34 Troubleshooting - Chevelle Tech

Chevelle Tech General Tech Area
Please try and post in specific forums

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 2 (permalink) Old Jun 4th, 08, 8:53 AM Thread Starter
 
Join Date: Sep 2006
Posts: 4
TCS L34 Troubleshooting

My TCS suddenly stopped working properly. I have stock 1970 L34 with M21. The system will not advance the timing in 3rd or 4th gear. Car runs fine without it, but it ran fine with the system working and I'd like to make it operational again; for originality. What steps should I take to determine cause for malfunction? All vacuum hoses are new and fuse is OK.
BrianL34 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Jun 4th, 08, 1:02 PM
Senior Tech Team
 
Join Date: Aug 1998
Location: Dallas, Tx, USA
Posts: 1,746
Re: TCS L34 Troubleshooting

Assuming you have a diagram of the circuit I would do the following.
1. With key on, pull the green wire off the Temp Override Switch.
Touch the green wire to ground, should here the Override Relay click
With the green wire on ground, verify that there is 12v on the DK Blue wire to the Vacuum Control Solenoid.
This verifys wether that the override relay is working correctly

2. To test the Vacuum control solenoid, ground the green wire, remove the black wire from the trans switch and ground it. This should energize the vacuum control solenoid. With the car running remove vacuum hose from dist and you should have manifold vacuum.

3. Tap into the black wire from the trans switch to the Vacuum control solenoid. Put a test light where you can see it while driving - +12v on one side and black wire tap on the other. Drive the car until it is at operating temp and in high gear, light should come on, if not something wrong with trans switch wiring or the switch itself.

Steve Strasemeier (70SS 396, Fathom Blue/White Stripes)
My 70SS
Steve S is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevelle Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address. Note, you will be sent a confirmation request to this address.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome