Heater Blower motor wiring - Chevelle Tech
Heating & Cooling Heating, cooling and air conditioning

LinkBack Thread Tools Search this Thread Display Modes
post #1 of 1 (permalink) Old May 2nd, 08, 11:19 PM Thread Starter
Lifetime Premium Member
Join Date: Dec 2004
Location: Colorado
Posts: 1,617
Heater Blower motor wiring

Just put a new Heater Blower Motor in my 70 .... the original motor did not have the wiring hooked up.

I have an orange wire coming from my harness that I would assume is the power that clips in. What about a ground? I see that someone cut a wire in my harness that looks like it may pair up with the power wire for the blower motor but not sure where the ground wire goes (and if that's actually it)

Anyone have a picture of where the ground goes and how its ran?



TC Member # 5462
70 Chevelle SS/396 4-Speed
DYNO RWHP: 364HP @ 5200 RPM / 426 Torque @ 3500 RPM
Birddog1970 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Chevelle Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address. Note, you will be sent a confirmation request to this address.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome