Dad's 89 Buick LeSabre unable to pull codes rough idle - Chevelle Tech
Engine AdvertisementGeneral Engine Discussion.

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 14 (permalink) Old Jul 26th, 10, 10:33 AM Thread Starter
Lifetime Premium Member
Dan
 
Join Date: Jan 2004
Location: dfw,texas
Posts: 1,454
Dad's 89 Buick LeSabre unable to pull codes rough idle

I made it to Ia. with my 66, Now Dad's car (89 Buick Lesabre 3800) is down, runs rough at idle and will intermitantly chug cruising down the road ocassionaly.
I tried jumping the serial port with a jumper wire, but can not get the check engine light to flash 12.
Any sugestions?
Thanks in advance!
p.s. I'm displaying proudly my TC stickers on my rear quarter window and have had several people ask about TC. Good site!

66 chevelle in the works
Team Chevelle Member #:2361
money pit

In God we Trust! USA
66dream is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old Jul 26th, 10, 10:44 AM
Gold Founding Member
 
Join Date: Aug 1998
Location: the Seasonally Frozen Wastelands
Posts: 10,489
Re: Dad's 89 Buick LeSabre unable to pull codes rough idle

1. Does the bulb light during bulb test with the key?

2. Jumping the correct terminals?

3. Defective ECM
Schurkey is offline  
post #3 of 14 (permalink) Old Jul 26th, 10, 10:57 AM Thread Starter
Lifetime Premium Member
Dan
 
Join Date: Jan 2004
Location: dfw,texas
Posts: 1,454
Re: Dad's 89 Buick LeSabre unable to pull codes rough idle

Quote:
Originally Posted by Schurkey View Post
1. Does the bulb light during bulb test with the key?

2. Jumping the correct terminals?

3. Defective ECM


Check engine light comes on with key
I think I'm jumping correct teminals, I tried sevral (suppose to be outside right top two)
Not sure how to check the ECM

66 chevelle in the works
Team Chevelle Member #:2361
money pit

In God we Trust! USA
66dream is offline  
post #4 of 14 (permalink) Old Jul 26th, 10, 12:14 PM
Super Mod
Rich
 
Join Date: Oct 1999
Location: Waverly, NE USA
Posts: 13,518
Garage
Re: Dad's 89 Buick LeSabre unable to pull codes rough idle

Does it have an EGR valve? It could be clogged up with carbon. If it has one, I'd suggest trying to clean the original as the replacements you'll get at auto parts stores won't work properly and a new one from GM will cost you a ton. Just get a new gasket, take it off and gently clean out the carbon and reinstall.

Since it is intermittant, you also might try getting a new gas cap. A good way to check this as a possible problem is to try driving it with the cap just loosly installed, not screwed down all the way and see if the problem goes away. Costs nothing to check it.
Rich-L79 is offline  
post #5 of 14 (permalink) Old Jul 26th, 10, 12:19 PM
Lifetime Premium Member
Randy
 
Join Date: Feb 2006
Location: Loganville, GA
Posts: 977
Re: Dad's 89 Buick LeSabre unable to pull codes rough idle

My parents 88 Bonneville did this as well, even acted up when they traded it in. It didn't show any codes at all, just would run rough and then run fine, like someone flipped a switch. Odd thing was if you unplugged a sensor, it would run fine in limp home mode, but go to acting up randomly once the sensor was plugged back in. Ended up being a bad ECM, according to the Pontiac dealer.

81 Camaro - CP autox ride
03 Suburban 2500 8.1L - Tow Pig
92 Dakota V8 - DD
67 El Camino - Sold
Randy 67EC is offline  
post #6 of 14 (permalink) Old Jul 26th, 10, 12:23 PM
Lifetime Premium Member
& Moderator
 
Join Date: Apr 2005
Location: North America
Posts: 15,554
Re: Dad's 89 Buick LeSabre unable to pull codes rough idle

Just for ref:
http://www.troublecodes.net/GM/
Mike is offline  
post #7 of 14 (permalink) Old Jul 26th, 10, 12:25 PM Thread Starter
Lifetime Premium Member
Dan
 
Join Date: Jan 2004
Location: dfw,texas
Posts: 1,454
Re: Dad's 89 Buick LeSabre unable to pull codes rough idle

thanks guys, I figured out pin terminals A&B were located, And looks like code 41.
Not sure what 41 is The vin on the car is 1G4HP54C5KH528942

Doesn't seem to match any of the listed in the link above

66 chevelle in the works
Team Chevelle Member #:2361
money pit

In God we Trust! USA
66dream is offline  
post #8 of 14 (permalink) Old Jul 26th, 10, 12:52 PM
Gold Founding Member
 
Join Date: Aug 1998
Location: the Seasonally Frozen Wastelands
Posts: 10,489
Re: Dad's 89 Buick LeSabre unable to pull codes rough idle

Quote:
Originally Posted by 66dream View Post
I think I'm jumping correct teminals, I tried sevral (suppose to be outside right top two)



This is what I can find. Are you jumpering A to B? Sometimes the connector is mounted "upside down", then instructions listing "upper right" terminals get you the wrong connectors.


Quote:
Originally Posted by 66dream View Post
Not sure how to check the ECM
Mostly, you don't. You check everything else, and if you don't find any hint of problem elsewhere...you stuff in a new computer.
Schurkey is offline  
post #9 of 14 (permalink) Old Jul 26th, 10, 1:10 PM
Lifetime Premium Member
& Moderator
 
Join Date: Apr 2005
Location: North America
Posts: 15,554
Re: Dad's 89 Buick LeSabre unable to pull codes rough idle

41 faulty ignition module cam sensor (3.8L)
http://www.troublecodes.net/GM/88-90_38C.shtml
Mike is offline  
post #10 of 14 (permalink) Old Jul 26th, 10, 6:23 PM Thread Starter
Lifetime Premium Member
Dan
 
Join Date: Jan 2004
Location: dfw,texas
Posts: 1,454
Re: Dad's 89 Buick LeSabre unable to pull codes rough idle

Quote:
Originally Posted by Mike View Post
41 faulty ignition module cam sensor (3.8L)
http://www.troublecodes.net/GM/88-90_38C.shtml

Got 2 cam sensors from junk yard but niether one helped. Now anyone know how to ohm one out?
Thanks again.

66 chevelle in the works
Team Chevelle Member #:2361
money pit

In God we Trust! USA
66dream is offline  
post #11 of 14 (permalink) Old Jul 26th, 10, 8:05 PM
Lifetime Premium Member
Mike
 
Join Date: May 2008
Location: New Hampshire
Posts: 1,309
Re: Dad's 89 Buick LeSabre unable to pull codes rough idle

There is a magnet on the cam gear that triggers the cam sensor, it could be broken.
mwiggett is offline  
post #12 of 14 (permalink) Old Jul 26th, 10, 8:08 PM
Lifetime Premium Member
& Moderator
 
Join Date: Apr 2005
Location: North America
Posts: 15,554
Re: Dad's 89 Buick LeSabre unable to pull codes rough idle

That code also refers to the circuit to the cam sensor so your trouble could be in the wiring and not just the sensor.
As you've tried 2 sensors ,I'd look at the wiring.
You can get the free wiring diagram by signing up to Autozone.
Add your vehicle ,then select Vehicle Repair Guides ,then select Chassis Electrical ,then Wiring Diagrams.
Your cam sensor wiring is on fig 5.
Mike is offline  
post #13 of 14 (permalink) Old Jul 26th, 10, 8:10 PM
Senior Tech Team
Chevelle Doctor
 
Join Date: Aug 1998
Location: Ft Wayne In.
Posts: 12,602
Re: Dad's 89 Buick LeSabre unable to pull codes rough idle

Quote:
Originally Posted by Mike View Post
,I'd look at the wiring.
Or the ecm. Did it flash a 12 also?

Authentication and pre-purchase inspection service still available. PM me for more information.
Still looking for that elusive 76 Nova SS.
People who have nothing better to do than b!tch about signatures need to get a life.
70 Chevelle L78/M21
10 Avalanche LT 1500 4wd
06 Equinox
Dave Birdwell is online now  
post #14 of 14 (permalink) Old Jul 27th, 10, 7:41 AM Thread Starter
Lifetime Premium Member
Dan
 
Join Date: Jan 2004
Location: dfw,texas
Posts: 1,454
Re: Dad's 89 Buick LeSabre unable to pull codes rough idle

Quote:
Originally Posted by Dave Birdwell View Post
Or the ecm. Did it flash a 12 also?

It did flash 12 first. Thanks guys for all your help, Dad has decided to junk it and got a 96 Voyager yesterday.

66 chevelle in the works
Team Chevelle Member #:2361
money pit

In God we Trust! USA
66dream is offline  
Sponsored Links
Advertisement
 
Reply
Gear in this thread - Powered by O'Reilly Auto Parts

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevelle Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address. Note, you will be sent a confirmation request to this address.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome