2003 yukon blower motor issues - Chevelle Tech
Misc (NON CHEVELLE AUTOMOTIVE TECH) This section is for the Non-Chevelle Related automotive questions/answers or discussion.

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 6 (permalink) Old Jun 10th, 13, 8:10 PM Thread Starter
Tech Team
Wayne
 
Join Date: Oct 2010
Location: MARYLAND
Posts: 407
2003 yukon blower motor issues

anybody ever have any blower motor problems or resistor issues with a 2003 Yukon, Tahoe dual zone electronic controls.

1967 Chevelle SS 396
1966 Impala Convertible
1987 Short Bed Silverado
wjspindler is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old Jun 10th, 13, 8:19 PM
Lifetime Premium Member
Doug Davis
 
Join Date: May 2006
Location: Lake Charles, LA
Posts: 6,187
Re: 2003 yukon blower motor issues

My Z71 is an 02, and the 1st speed went out. If you do an internet search you'll find that it is a very common problem, but no recall was ever issued on these years!

66 Chevelle
350/400 Turbo
12 Bolt Eaton Posi w/3:73's
Team Chevelle Member # 3540
davis95 is offline  
post #3 of 6 (permalink) Old Jun 10th, 13, 9:20 PM
Tech Team
Ken K.
 
Join Date: Jan 2013
Location: SE Michigan
Posts: 215
Re: 2003 yukon blower motor issues

When I worked at a dealership we replaced plenty of blower resistors. Usually they would loose low speed then the next then the next. I also have an 02 Z71 and never had a problem with it. Rarely would we replace a blower motor but at times the connections to blower would get corroded and motor would have to be replaced. I do not believe the type of HVAC system you have has anything to do with the resistor problem.
SKIS69SS is offline  
post #4 of 6 (permalink) Old Jun 10th, 13, 9:47 PM
Tech Team
 
Join Date: Jul 2010
Location: Rt66
Posts: 435
Re: 2003 yukon blower motor issues

Hey Wayne, One year ago yesterday the local Chev dlrshp replaced my resistor and connector under recall Special Policy 102400. Work Order also makes note T5817 Special Coverage 10240: Replace HVAC Module Connector and Resistor.
Mine was a '06 Silverado but there were several yrs there that had the problem. I learned of the recall and correct 800-phone number on a youtube vid. Saved me the dough of parts and the labor of doing it myself.
Hope the Recall is still Recalling for ya.
64play is offline  
post #5 of 6 (permalink) Old Jun 10th, 13, 10:49 PM Thread Starter
Tech Team
Wayne
 
Join Date: Oct 2010
Location: MARYLAND
Posts: 407
Re: 2003 yukon blower motor issues

Thanks Dan I will check into it with my fingers crossed appreciate the info.

1967 Chevelle SS 396
1966 Impala Convertible
1987 Short Bed Silverado
wjspindler is offline  
post #6 of 6 (permalink) Old Jun 10th, 13, 10:55 PM
Lifetime Premium Member
leo
 
Join Date: Oct 2003
Location: Colonial Beach, Va
Posts: 9,932
Re: 2003 yukon blower motor issues

www.recalls.gov

Leo Paugh
Maryland Chevelle Club #017
A.C.E.S.#3731
progress has little to do with speed, but lots to do with direction
www.mdchevelleclub.com
LeoP is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevelle Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address. Note, you will be sent a confirmation request to this address.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome