Anyone had this happen??? - Chevelle Tech
Brakes, Suspension & Steering Conversion questions & more.

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 6 (permalink) Old Jun 13th, 05, 11:40 AM Thread Starter
Tech Team
 
Join Date: Sep 2004
Location: oregon
Posts: 65
Anyone had this happen???

Over the winter I did a complete Polygraphite front end rebuild. I also put new 1 inch lowering springs on the front with stack height in the rear and new KYB gas shocks. Well anyway, my front upper control arm on the passanger side lost the nut in the rear bushing and the bushing came out!!! I did not press the bushings in, I had a local shop do it. Here are my questions. 1 - is this common? 2 - should the shop be willing to press the new bushings in at no cost? 3 - Am I just an idiot for not tightening the thing to ensure it was tight? The other bolt in the control arm bushing is fine as is the driver side control arm bushing bolts.
oregonchevelle+ is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old Jun 13th, 05, 12:37 PM
Senior Tech Team
heathensumbitch
 
Join Date: Jan 2001
Location: San Diego
Posts: 2,021
Send a message via AIM to Cecil Send a message via Yahoo to Cecil
Re: Anyone had this happen???

Yes, it happens regularly. Keep a 9/16 wrench handy and give 'em a good tug whenever you get a chance. Don't know about the shop, since it's not really their fault...

"Let not the sands of time get in your lunch..." Monty Python
Cecil is offline  
post #3 of 6 (permalink) Old Jun 13th, 05, 1:12 PM
Senior Tech Team
Mark
 
Join Date: May 2001
Location: Wheaton, IL USA
Posts: 6,406
Re: Anyone had this happen???

FYI, the compression lock nuts are only good for one compression. If that's the type you are using you might want to consider nylock or similar as a replacement, and/or use loctite on the threads for good measure.

Mark

1970 SS396
Lewis Racing Engines (Wolfplace) 489:
634 HP @ 6000rpm
627 Lb-ft @ 4,000rpm

ProSystems SV1
Gear Vendors Overdrive
Moser 12 Bolt
Alumitech Radiator
Pypes Exhaust

Dyno
'70 Chevelle
'70 Chevelle 2
Xtreme70SS396 is offline  
post #4 of 6 (permalink) Old Jun 13th, 05, 2:24 PM Thread Starter
Tech Team
 
Join Date: Sep 2004
Location: oregon
Posts: 65
Re: Anyone had this happen???

No nuts just the bolt threaded in there. I will be checking for now on.
oregonchevelle+ is offline  
post #5 of 6 (permalink) Old Jun 13th, 05, 3:01 PM
Tech Team
 
Join Date: Dec 1999
Location: Southhaven, MS, USA
Posts: 410
Re: Anyone had this happen???

Happens all the time
Mine were loose before cb05 locktight them.

Mike
TC#355
aces member #03260
69SS396
69 convertible
68 convertible
72 Olds 442 convertible
(JBROWN)
http://www.chevelles.com/forums/imag...4&type=profile
69SSRat is offline  
post #6 of 6 (permalink) Old Jun 13th, 05, 3:34 PM
Senior Tech Team
Mark
 
Join Date: May 2001
Location: Wheaton, IL USA
Posts: 6,406
Re: Anyone had this happen???

Sorry, I converted mine when I went to the offset shaft to nuts. Sounds like loctite is your only bet + regular checking.

Mark

1970 SS396
Lewis Racing Engines (Wolfplace) 489:
634 HP @ 6000rpm
627 Lb-ft @ 4,000rpm

ProSystems SV1
Gear Vendors Overdrive
Moser 12 Bolt
Alumitech Radiator
Pypes Exhaust

Dyno
'70 Chevelle
'70 Chevelle 2
Xtreme70SS396 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevelle Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address. Note, you will be sent a confirmation request to this address.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
What would happen if I ran 91 octane? OUChevelleSS Performance 7 Apr 6th, 05 5:56 PM
What would happen with no throttle return spring? OUChevelleSS Performance 3 Dec 8th, 04 3:14 PM
engine problems. What happen???? german Engine 4 Aug 12th, 03 11:46 PM
how could this happen chevelle 71 Engine 1 Jan 20th, 03 1:43 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome