Parts do not work from OPGI - Page 3 - Chevelle Tech
Original Parts Group Incorporated Original Parts Group Incorporated

 
LinkBack Thread Tools Search this Thread Display Modes
post #31 of 32 (permalink) Old Feb 16th, 13, 12:20 PM
Tech Team
 
Join Date: Jul 2012
Location: Ct
Posts: 119
Re: Parts do not work from OPGI

someone needs to start a company to re-pop this stuff correctly. seems to be a no brainer that you could make $$$ and be unstoppable in the restoration world. they might cost more, but the parts would fit. how many of us would be willing to pay 5-20% more for quality stuff built correctly...i sure as hell would.

Sent from my SCH-I510 using AutoGuide.Com Free App
hotrodjunky1982 is offline  
Sponsored Links
Advertisement
 
post #32 of 32 (permalink) Old Feb 19th, 13, 12:33 AM
Bill
 
Join Date: Feb 2013
Location: ID
Posts: 13
Re: Parts do not work from OPGI

Well i do agree to a point BUT there is hardly any used parts out there and i have had things to that dont quite fit BUT on another note it sometimes better than nothing when the originals are gone all you have is repo stuff I wish it was a perfect world and we could still buy factory stuff
MAGILICUDY is offline  
Sponsored Links
Advertisement
 
 

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevelle Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address. Note, you will be sent a confirmation request to this address.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome